I have tried almost every imaginable option I could find online to put in the 10-evdev.conf file in the xorg.conf.d directory so as to disable the dragging action of my touchscreen (eGalax Inc. Touch) but I have not been able to. The touchscreen is recognized as a tablet device but I can live with that. If I give some Options such as Option "Ignore" "on" under the following section in 10-evdev.conf then it works (meaning, it disables the touchscreen). If I do the same under the touchscreen catchall, it does not work! Also, in the xorg log, I can see that it is recognized as a tablet (I believe this is a bug in the kernel but it really doesn't matter as long as I can configure the touchscreen and have it working properly)

Section "InputClass"
  Identifier "evdev tablet catchall
  MatchIsTablet "on"
  MatchDevicePath "/dev/input/event*"
  Driver "evdev"

Now, my problem is that no matter what Option I've tried, I am not able to disable dragging. If I touch the screen and drag my finger across the screen, it draws a rectangle or actually drags the icons on the desktop. All I need from the touchscreen is click (tap) functionality since I'm going to be using is as a kiosk. Can anyone give me the right configuration to disable dragging? Thanks Nahom

1 Answer 1


OK, found the solution: You need the Linux eGalax driver from here ....
After you unzip this download, look in the Programming Guide in the /Guide directory. It contains lengthy instructions. I did not follow them all, but note that my PC only has a single point touchscreen. What I did, which worked:
Run sudo sh setup.sh as indicated at section 3.1.

then reboot

Hope you succeed as well.

  • The eGalax driver from the manufacturer has issues. I was hoping to be able to disable dragging while still using the evdev driver that came with Ubuntu.
    – nahom
    Sep 10, 2015 at 9:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .