0

I have freshly installed Ubuntu 15.04 recently. I haven't noticed the problem but I could not play music from any of my two browsers, which are Firefox and Chrome, but I can hear sound once I have plugged in my earphones. I have also checked alsamixer and unmuted the devices. I have used the commands:

alsa force-reload

but it did not work so I tried reinstalling it with the following commands:

sudo apt-get remove --purge alsa-base pulse

sudo apt-get install alsa-base pulseaudio

Then used alsa force-reload again. I restarted my computer, after that, I cannot see the speaker icon which is normally located above and when I checked my system settings it became like this: Speaker seems to not be detected and the look of the Sound Settings looks off and you cannot see the speaker icon which is normally beside the "En" box

Speaker seems to not be detected and the look of the Sound Settings looks off and you cannot see the speaker icon which is normally beside the "En" box

How do I fix this? Do I need another fresh install of Ubuntu 15.04?

  • Go in settings--> Sound and show me the screenshot of Output in it. – We are Borg Sep 7 '15 at 13:44
  • @WeareBorg The screenshot is already shown above. – Julie Anne Gala Sep 8 '15 at 11:33
  • Last I knew, screenshots don't look garbled like you have, they look something like postimg.org/image/sraym8wup . – We are Borg Sep 8 '15 at 11:35
  • @WeareBorg Yes they did look like that before I reinstalled alsa and pulse audio. After restarting, it became like that and the speaker (which controls the sound) does not appear on the top right area of the screen. I'm looking for a reason as to why it became like that. – Julie Anne Gala Sep 8 '15 at 11:37
  • Ok, one question, so how have you connected your speakers if not at the green port where headphones go. Are those monitor speakers...and you want to use HDMI? If that's the case, do you have AMD graphics card? – We are Borg Sep 8 '15 at 11:41
0

You can follow these steps to debug your audio.

If you want to know more for ALSA and PulseAudio, you can check this answer.

Also you could use GUI to change your device preferences like:

  • (For Gnome) Sound Settings (which is a part of gnome-control-center)
  • (For KDE) Audio and video settings - KDE control module
  • pavucontrol

If your earphones use USB, then they are "seen" as a different device.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.