2

I' m trying to burn a simple mp3 data CD but I can' t get k3b/brasero/xfburn to work. Basically K3b says 'Please insert an empty or appendable medium', like if there wasn' t a CD in the DVD recorder. Similar error messages are shown with other tools. However K3b can recognize the DVD drive, because it can show detailed information about it.

$ LANG=C sudo lshw -C disk output

*-cdrom                 
   description: DVD-RAM writer
   product: DVDRW   DVR-K17B
   vendor: PIONEER
   physical id: 0.0.0
   bus info: scsi@0:0.0.0
   logical name: /dev/cdrom
   logical name: /dev/sr0
   version: 1.02
   capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
   configuration: ansiversion=5 status=ready
 *-medium
      physical id: 0
      logical name: /dev/cdrom

I' ve added this configuration to my /etc/fstab file:

# cdrom
/dev/sr0  /media/cdrom0  iso9660  rw,user,noauto,unhide

When I execute:

mount -a

I don' t get any error message.

If I execute: mount /dev/sr0 /media/cdrom0

I get: mount: /dev/sr0: can t read superblock

On checking dmesg | tail, I can see: [ 1021.762622] EXT4-fs (sr0): unable to read superblock [ 1022.026866] sr 0:0:0:0: [sr0]
[ 1022.026882] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE [ 1022.026890] sr 0:0:0:0: [sr0]
[ 1022.026895] Sense Key : Blank Check [current] [ 1022.026905] sr 0:0:0:0: [sr0]
[ 1022.026910] Add. Sense: No additional sense information [ 1022.026917] sr 0:0:0:0: [sr0] CDB: [ 1022.026921] Read(10): 28 00 00 00 00 00 00 00 01 00 [ 1022.026980] FAT-fs (sr0): unable to read boot sector

Does anyone know how to fix this?

0

"If I execute: mount /dev/sr0 /media/cdrom0"

one problem may be:

overdefined! If fstab is working fine just say

mount /dev/sr0

That's it! Now mount must work.

other problem can be:

EXT4-fs (sr0): unable to read superblock

you probably do NOT have ext4 on the CD! I'm not aware this exists.

This means not to type the type in the CLI is striking back.

Look at the man page to name the type. Most probably a

-t iso9660

will do the job. Type in the type and it will work on CLI.

For modern SD-cards look out for exfat support. Something like

install exfat-utils

And for DVD-RAM you need UDFtools.


DVD-RAM is very old so there is no new info. Old and underestimated. DVD-RAM on Ubuntu Linux is easy. I use Ubuntu 16.10 with XFCE4 but that does not matter at all.

Why DVD-RAM? Because it is more reliable and more stable archiving data. See Wikipedia for details on DVD-RAM.

However, DVD-RAM is rather an external drive than a DVD to write on. Not all drives can write and read. However, most modern Laptop and Computer optical drives can.

Careful: DVD-RAM is slow by modern means. Don't force the mount and umount to break.

We have to format it as UDF file system. This is the appropriate FS for the DVD-RAM (I do not quote the details here, use duckduckgo.com)

Know your CD-Writer: Mount a CD, with „mount“ watch out for the name. Like /dev/sr0.

Take the DVD-RAM out of the cartridge if necessary, put it in your drive and reboot.

Prepare:

sudo apt-get install udftools sudo apt-get install dvd+rw-tools

Make a mount point:

sudo mkdir /mnt/dvdram0

and adapt the user rights etc. You need to adapt the rights again for the mounted DVD-RAM (different than vfat floppy or external drive).

Adapt the fstab:

sudo vim /etc/fstab

For automatic mount enter a new line like

/dev/sr0 /mnt/dvdram0 auto user,users,rw,auto,exec,utf8 0 0

The first auto may better be "udf". The second auto depends on you: Try noauto if the boot process hangs.

Format the DVD-RAM:

sudo mkudffs --media-type=dvdram /dev/sr0

The default options for mkudffs probably match your needs. Otherwise: man mkudffs !

Mount the DVD-RAM:

mount /dev/sr0

should do it, otherwise use as sudo mount /dev/sr0. With the fstab entry it will be found.

When you ask your CLI now with mount it should answer something like:

/dev/sr0 on /mnt/dvdram0 type udf (rw,nosuid,nodev,relatime,utf8,user=myname)

Now again adapt the access rights for the mounted(!) drive:

sudo chown myname /mnt/dvdram0 sudo chmod u+rwx /mnt/dvdram0

Test your access rights:

mkdir /mnt/dvdram0/mydirectory

without sudo it should work. Otherwise check the rights.

Do a reboot now or restart all relevant services.

So now we have

installed the tools
prepared to mount
formatted the DVD-RAM
mounted it in the file system
adapted the user access

It shall be available in the file manager like a normal drive. Watch out for /mnt/dvdram0 (and in Nemo create a bookmark).

Unmounting takes time because of write completion. It is done from CLI or try to find a way in your browser.

What did I forget? What was wromng?

Better way to unmount??

0

Referring to the previous /etc/fstab proposals, I would suggest the following version:

/dev/sr0 /cdrom auto user,users,rw,auto,exec,utf8,nofail,x-gvfs-show 0 0

Without nofail my system stopped at reboot when the device was not connected with message entering emergency mode.

Without x-gvfs-show the dvd directory was not visible in nautilus.

Btw, I'm using ubuntu 18.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.