0

It seems like a repetitive question, but its is not. If it is, please guide me.

I have bought a new PC with following configuration

  • Motherboard - Gigabyte (Socket 1150, Intel H81, GA-H81M-S1)
  • Processor - Intel i5-4460 3.2GHz

  • HDD (500GB) -

    • C: 100GB with windows 8.1 installed (NTFS)
    • D: 250GB empty (NTFS)
    • E: 125GB empty (NTFS)
  • RAM - 8GB (Transcend)
  • Graphics Card - Nvidia GT610 2GB

In my C: drive, i have windows 8.1 already and i am trying to install Ubuntu 15.04 alongside Windows 8.1.

I downloaded the iso for the same and burn it on DVD. And here are the steps i am following:

  • Load it as a live OS DVD. enter image description here

  • Live OS loaded. enter image description here

  • Enabled the internet. enter image description here

  • Started installing Ubuntu 15.04 enter image description here

  • Selecting options. enter image description here

  • On clicking continue in previous step i got this message, i thought it might be a warning tried to skip this. enter image description here

  • It is not able to detect any operating system, hence i selected the option "Something Else" enter image description here

  • As you can see all my parititions. enter image description here

  • I tried creating swap of 8GB, same as the RAM size in the drive representing E: drive for windows. enter image description here

  • I got some warning for data back up which seems fine. enter image description here

  • Then it flagged an error, swap cannot be created. enter image description here

  • Then i created rest of the space of E: drive (in respect of windows) as ext4 partition for / (root)

  • Then on clicking continue, i again got this error and i can't continue further, hence i have to forcefully shutdown. enter image description here

Some one told me to upgrade bios, i tried doing it but I did something horribly wrong, after that computer stopped working. Luckily I had taken the backup of current bios, hence able to revert back the previous state. If bios upgrade is required, please suggest which one? Else, what should I do to install Ubuntu 15.04?

As per further suggestions, i tried further steps:

I even tried disabling the UEFI mode from boot setup: - Those are the two options i was able to find related to UEFI mode: enter image description here

enter image description here

  • creating swap enter image description here

  • creating ext4 partition enter image description here

  • this is how the final structure. enter image description here

  • clicking continue, got the same error as swap cannot be created. enter image description here

Please Help, i think this is not going to work out?

  • I tried with simple ext4 partition creation, not having swap. It failed at the end.

enter image description here

4
  • See my answer to this question. Yours is a duplicate, but I can't flag it as such because the duplicate question is new enough that its answers have yet to be accepted or receive up-votes. – Rod Smith Sep 7 '15 at 14:58
  • @RodSmith thanks for the comment, i tried same by changing options related to UEFI. Please find my updated question with screenshots. Please suggest, is there anything i am missing? It would be a great help. – Vishwadeep Singh Sep 8 '15 at 3:57
  • I actually cant remove windows too and reinstall coz it came already installed and i dont have the DVD for reinstalling. So what do you suggest? Is there any else distro (Centos etc) i can try? – Vishwadeep Singh Sep 8 '15 at 4:03
  • You must force Ubuntu to install in BIOS/CSM/legacy mode. You can usually do this by using the computer's built-in boot manager and launching the Ubuntu installation disk with the option that lacks the string "UEFI" in the description. Unfortunately, this detail varies from one computer to another, so I can't be more precise or even promise that it will work. If it doesn't work, you may need to delete the EFI/BOOT/bootx64.efi file from the boot medium to force a BIOS-mode boot. I wrote all of this in my answer to the linked-to question. – Rod Smith Sep 10 '15 at 13:21
0

Ubuntu and all other GNU/linux doesn't work under NTFS. Format one of your drives as ext4 in which you want to install Ubuntu.

For example you may click on /dev/sda6 and click "-" to delete ntfs partition. Then you may click "+" and make that ext4 partition and then proceed.

22
  • I will try this. But same i did with making it as free volume too, coz i was thinking the same. Hence i am little doubtful about this solution. Is there any possibility related to bios? But still i will try once again and will get back to you. – Vishwadeep Singh Sep 7 '15 at 9:38
  • 1
    I think installing ubuntu in legacy(not UEFI) with secure boot off will be good. I dont think there is anything wrong with BIOS. – kashish Sep 7 '15 at 10:43
  • Ok. then will start focussing on HD format type. Let me check and will get back to you. – Vishwadeep Singh Sep 7 '15 at 10:53
  • Nope buddy, It didn't help. Please suggest anything else i might be missing? – Vishwadeep Singh Sep 8 '15 at 3:58
  • Refer this – kashish Sep 8 '15 at 8:13
0

first format a drive upto 30GB or more and then try to dual boot by the above steps.Make sure the space where u want to install ubuntu remains unallocated.

2
  • yup. i tried with 120GB. and it was unallocated, displaying free space in installation step. what is this UEFI warning? – Vishwadeep Singh Sep 7 '15 at 10:22
  • ignore the UEFI warning – roshande Oct 3 '15 at 1:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.