I am attempting to install 'Ubuntu Server 14.04.3 LTS' with a Flashdrive (there is no DVD/CD onboard). However, after keyboard selection a notification is presented saying:

"Your installation CD-ROM couldn't be mounted. This probably means that the CD-ROM was not in the drive. If so you can insert it and try again."

Trying to check Disk Integrity fails because No CD-ROM is mounted.

Things like "Intel Speedstep" and "Secure Boot" are disabled. I've tried UEFI and Legacy installs both with same results.

I've tried the solution presented here with no success (even though it's to a similar but different problem).

I've also tried multiple different Bootable USB programs:

  1. Ubuntu's default
  2. UNetbootin
  3. YUMI
  4. Rufus

Computer: Lenovo ThinkServer TS130

Notice: I am a novice to this and thus answers with required knowledge I might not understand.

Update Info:

On USB boot, after selecting install - where the screen is black a few quick text notification are flashed.

The first one at the top of the screen:

 ACPI PCC probe failed.
 tpm_tis 00:06: A TPM error (6) occurred attempting to read a pcr value
 Starting system log daemon: syslogd, klogd.

The second one at the bottom of the screen:

 mount: mounting /dev/sda on /media failed: Invalid argument
 unmount: can't unmount /media: invalid argument
 mount: mounting /dev/sda on /media failed: Invalid argument
 mount: mounting /dev/sda1 on /media failed: Invalid argument
 unmount: can't unmount /media: invalid argument
 mount: mounting /dev/sda1 on /media failed: Invalid argument
 mount: mounting /dev/sda2 on /media failed: Invalid argument
 unmount: can't unmount /media: invalid argument*
 mount: mounting /dev/sda2 on /media failed: Invalid argument
 Trying to enable the frame buffer...
  • refer here
    – Ravan
    Sep 7 '15 at 4:01
  • I don't know what's wrong, but since you've tried almost everything take a look at this: askubuntu.com/questions/287064/…
    – karel
    Sep 7 '15 at 5:20
  • it sounds like the usb is not the first boot device
    – mchid
    Sep 7 '15 at 5:33
  • Another thing to check is md5sum of the ISO that you downloaded.
    – P.-H. Lin
    Sep 7 '15 at 6:05
  • 2
    Try to avoid USB 3.0 ports, if possible. Try to use another usb port and check bios settings due to USB ports mode. I've seen this before on modern asus motherboards - problem was on stupid autoconfig USB features in BIOS.
    – itfdev
    Sep 7 '15 at 6:13

Just to note - I managed to go over this problem like this:

Once I get the "Your installation CD-ROM couldn't be mounted..." message and I'm back at the main Ubuntu Server install screen, I simply plugged the USB thumbdrive out, then plugged it in again, and then after pressing the "detect CD" option, I got "The CD-ROM autodetection was successful... The installation will now continue." ... and so the installation continued.

  • 2
    Saved me probably an hour of troubleshooting today. Thanks!
    – raphnguyen
    Jul 6 '16 at 1:59
  • 1
    Definitely a lot simpler than the accepted answer.
    – zmbq
    Jul 24 '16 at 8:30
  • 2
    Absolute lifesaver!
    – Fencer04
    Feb 26 '17 at 3:54
  • 1
    For what it's worth, this works right when it tells you it can't detect the CDROM. Right there, unplug and immediately replug in the USB drive, and try again, it'll work. Mar 22 '17 at 2:52
  • I lost hours on this before I found your solution. Apr 19 '17 at 9:59

I usually use Rufus for USB images and when I create a bootable disk using ISO images for Ubuntu Server, it breaks at mounting CD/ROM device stage but when I change it to DD Image it works.

Rufus DD Image Option

  • 2
    @IbrahimBeytekin I had the exact same environment and your answer helped me, am not sure why people have down voted you. I will file a petition to have the downvotes cleared. Thanks for taking time to post the solution.
    – James Wong
    Jun 16 '16 at 6:28
  • This works for me too (Lubuntu for an old Dell)
    – Luke Vo
    Sep 10 '19 at 5:13

Ubuntu Server Install has been broken for many versions. I don't think it will ever be corrected. If you utilize utilities to create a USB installer, you should be fine. However, if you want advanced mode options such as creating a UEFI only boot media, you will have to do some extra work. Here is the easiest solution I have found. Make your UEFI boot stick, whichever method you prefer.(example is for fat file structure mounted to sbd1 - alter if you are using something else) Copy the .ISO file you downloaded to that same stick. Boot away. When you get to the CD error, do the following.

  1. Press Alt-F2
  2. Enter to start new terminal session
  3. mkdir /media/usb
  4. mount -t vfat /dev/sdb1 /media/usb
  5. mount -o loop path/to/iso/file/UBUNTUSERVER.ISO /cdrom
  6. Press Alt-F1
  7. Say "No" to search again. Then click "Detect and mount CD-ROM"

After downloading the .iso image from Ubuntu's web page you have to make sure that during download the file is not corrupted by checking the .iso file in terminal with md5sum and sha256sum. To me:

  • download the .iso file again
  • check its originality withs md5sum and sha256sum (in terminal locate the downloaded file "cd download_directory" then hit "sudo md5sum FILE NAME.iso and "sudo sha256sum FILE NAME.iso" compare the both with given ones in the Ubuntu's web page) if it correct
  • then hit "dash" search for "startup Disk Creator"
  • there hit the "other" locate the .iso file then
  • there format the "flash-drive"
  • there at least give an extra 1 GB more free space
  • Hit"Make Startup Disk" when finishes Restart the PC
  • When restarting hit "the F12 button" to select the boot option.
  • From there select "Removable Flash Drive etc"
  • There it should work. At least it worked for me.

I would suggest to make a new bootable usb stick using dd.

  1. Find your usb device

    sudo fdisk -l //example /dev/sdb
  2. Unmount it.

    sudo umount /dev/sdb
  3. Copy iso using dd

    sudo dd if=/path/to/ubuntu/installtion/media.iso of=/dev/sdb bs=1M

Plug and install.

  1. Download Ubuntu Server iso-image: https://www.ubuntu.com/download/server/thank-you?version=16.04.1&architecture=amd64
  2. Download UNetbooting:http://launchpad.net/unetbootin/trunk/625/+download/unetbootin-windows-625.exe , start it and create bootable USB installer by using Ubuntu Server iso-image. Here is guide how to use UNetbooting software:"www.htpcbeginner.com/install-ubuntu-server-from-usb/"
  3. After bootable USB installer creation is complete shutdown UNetbooting and copy Ubuntu Server iso-image into USB stick root directory.
  4. Now installation should work without CD-ROM error.

I found a solution. I was running unetbootin, and I got the same issue. But solved it like so:

  1. Start up live CD.
  2. Without touching anything open a terminal and type:

    sudo umount -l -r -f /cdrom
  3. Install Ubuntu without any issue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.