1

I recently went to the YouTube website and noticed that it was telling me that my Adobe Flash plugin was being allowed. Now this is very strange, because I do not use Flash for security reasons, and to my knowledge, don't have it installed. Yesterday I installed Shumway, but I have used it before and have not noticed that it installs an Adobe Flash plugin. This is the offending Adobe Flash plugin:

enter image description here

Is this something to do with Shumway? Or what is it? I don't remember installing it... Could it be something malicious? I installed Ubuntu GNOME 15.04 some time ago and have not noticed the appearance of this plugin before... Is it anything to worry about? If I look in my recently updated things in Firefox, it is the only one there, and its date is today, but I definitely haven't done anything today to get that as far as I know...

Information Update:

I ran a check of all the files that were created today, and I found it I think:

-rw-r--r-- 1 root        root        19264896 Sep  6 14:48 /usr/lib/flashplugin-installer/libflashplayer.so

It was hours apart from the other files created today, so I would think that it was the only one linked to this that was created. Another thing is that I had my computer on in the morning and then turned it off, but then this file was created around 28 minutes after I started it back up again. The entire extract from that time frame was:

107458 -rw-r----- 1 clamav           adm                  62107 Sep  6 14:25 /var/log/clamav/freshclam.log.1
107459 -rw-r----- 1 syslog           adm                 152664 Sep  6 14:25 /var/log/auth.log.1
107460 -rw------- 1 arthur-dent      arthur-dent           5212 Sep  6 14:31 /home/arthur-dent/.cache/mozilla/firefox/5ifhm5wp.default/directoryLinks.       json
107461 -rw-r--r-- 1 root             root                     0 Sep  6 14:46 /var/lib/apt-xapian-index/update-timestamp
107462 -rw-r--r-- 1 root             root                     0 Sep  6 14:46 /var/lib/apt/periodic/update-stamp
107463 -rw-r--r-- 1 root             root                     0 Sep  6 14:47 /var/cache/apt-xapian-index/index.2/flintlock
107464 -rw-r--r-- 1 root             root               3618000 Sep  6 14:47 /var/lib/apt-xapian-index/cataloged_times.p
107465 -rw-r--r-- 1 root             root              54444032 Sep  6 14:47 /var/cache/apt-xapian-index/index.2/termlist.DB
107466 -rw-r--r-- 1 root             root                 16384 Sep  6 14:47 /var/cache/apt-xapian-index/index.2/synonym.DB
107467 -rw-r--r-- 1 root             root              71860224 Sep  6 14:47 /var/cache/apt-xapian-index/index.2/postlist.DB
107468 -rw-r--r-- 1 root             root               6127616 Sep  6 14:47 /var/cache/apt-xapian-index/index.2/spelling.DB
107469 -rw-r--r-- 1 root             root               2285568 Sep  6 14:47 /var/cache/apt-xapian-index/index.2/record.DB
107470 -rw-r--r-- 1 root             root                  1114 Sep  6 14:47 /var/cache/apt-xapian-index/index.2/postlist.baseB
107471 -rw-r--r-- 1 root             root                   849 Sep  6 14:47 /var/cache/apt-xapian-index/index.2/termlist.baseB
107472 -rw-r--r-- 1 root             root                    14 Sep  6 14:47 /var/cache/apt-xapian-index/index.2/synonym.baseB
107473 -rw-r--r-- 1 root             root                    80 Sep  6 14:47 /var/cache/apt-xapian-index/index.2/spelling.baseB
107474 -rw-r--r-- 1 root             root                    51 Sep  6 14:47 /var/cache/apt-xapian-index/index.2/record.baseB
107475 -rw-r----- 1 clamav           adm                  41702 Sep  6 14:47 /var/log/clamav/clamav.log.1
107476 -rw-r----- 1 syslog           adm                6044563 Sep  6 14:47 /var/log/ufw.log.1
107477 -rw-r----- 1 syslog           adm                7817152 Sep  6 14:47 /var/log/kern.log.1
107478 -rw-r----- 1 syslog           adm               18982650 Sep  6 14:47 /var/log/syslog.1
107479 -rw-r--r-- 1 root             root                  1766 Sep  6 14:47 /var/lib/logrotate/status
107480 -rw-r--r-- 1 man              root               1228800 Sep  6 14:47 /var/cache/man/index.db
107481 -rw------- 1 root             lp                     594 Sep  6 14:48 /etc/cups/printers.conf.O
107482 -rw-r----- 1 root             mlocate            8797722 Sep  6 14:48 /var/lib/mlocate/mlocate.db
107483 -rw-r--r-- 1 root             root                   111 Sep  6 14:48 /var/lib/dpkg/alternatives/mozilla-flashplugin
107484 -rw-r--r-- 1 root             root                  1638 Sep  6 14:48 /var/log/alternatives.log
107485 -rw-r--r-- 1 root             root                     0 Sep  6 14:48 /var/lib/update-notifier/package-data-downloads/flashplugin-installer
107486 -rw------- 1 root             root                     9 Sep  6 14:48 /var/spool/anacron/cron.daily
107487 -rw-r----- 1 syslog           adm                    114 Sep  6 14:48 /var/log/mail.log
107488 -rw-r----- 1 syslog           adm                    114 Sep  6 14:48 /var/log/mail.err
-rw-r--r-- 1 root        root        19264896 Sep  6 14:48 /usr/lib/flashplugin-installer/libflashplayer.so

The contents of /var/log/dpkg.log for today is:

1378 2015-09-06 14:23:50 startup archives unpack
1379 2015-09-06 14:23:57 upgrade numix-icon-theme:all 0.3+524~201509050731~ubuntu15.04.1 0.3+528~201509060731~ubuntu15.04.1
1380 2015-09-06 14:23:57 status half-configured numix-icon-theme:all 0.3+524~201509050731~ubuntu15.04.1
1381 2015-09-06 14:23:57 status unpacked numix-icon-theme:all 0.3+524~201509050731~ubuntu15.04.1
1382 2015-09-06 14:23:58 status half-installed numix-icon-theme:all 0.3+524~201509050731~ubuntu15.04.1
1383 2015-09-06 14:24:21 status half-installed numix-icon-theme:all 0.3+524~201509050731~ubuntu15.04.1
1384 2015-09-06 14:24:22 status unpacked numix-icon-theme:all 0.3+528~201509060731~ubuntu15.04.1
1385 2015-09-06 14:24:22 status unpacked numix-icon-theme:all 0.3+528~201509060731~ubuntu15.04.1
1386 2015-09-06 14:24:23 startup packages configure
1387 2015-09-06 14:24:23 configure numix-icon-theme:all 0.3+528~201509060731~ubuntu15.04.1 <none>
1388 2015-09-06 14:24:23 status unpacked numix-icon-theme:all 0.3+528~201509060731~ubuntu15.04.1
1389 2015-09-06 14:24:23 status half-configured numix-icon-theme:all 0.3+528~201509060731~ubuntu15.04.1
1390 2015-09-06 14:24:23 status installed numix-icon-theme:all 0.3+528~201509060731~ubuntu15.04.1
1391 2015-09-06 14:24:23 startup packages configure

The output of apt-cache policy flashplugin-installer is:

flashplugin-installer:
  Installed: 11.2.202.508ubuntu0.15.04.1
  Candidate: 11.2.202.508ubuntu0.15.04.1
  Version table:
 *** 11.2.202.508ubuntu0.15.04.1 0
        500 http://archive.ubuntu.com/ubuntu/ vivid-updates/multiverse amd64 Packages
        500 http://archive.ubuntu.com/ubuntu/ vivid-security/multiverse amd64 Packages
        100 /var/lib/dpkg/status
     11.2.202.457ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/multiverse amd64 Packages

I definitely did not intentionally install it. And I don't want it. So is it something malicious, or something installed in error? And there is no trace of it in the Ubuntu Software Center's History of all changes:

enter image description here


OS Information:

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.04
Release:    15.04
Codename:   vivid
Flavour: GNOME
GNOME Version: 3.16
  • You can get some clues by looking in the files /var/log/apt/history.log*. Also, if you have aptitude installed, run aptitude why flashplugin-installer. – Eric Carvalho Sep 6 '15 at 23:32
  • @EricCarvalho: The output of the second command was: i ubuntu-restricted-addons Recommends flashplugin-installer, and the other log suggested the same thing too... So I guess that I am fine then! Can you post that as an answer please so that I can accept it. :) – user364819 Sep 7 '15 at 16:23
2

APT maintains a history of operations in the files /var/log/apt/history.log and /var/log/apt/history.log.#.gz. Search for "flashplugin-installer" inside them and you should discover when the package was installed and if it was an automatic installation (as a dependency of another package).

aptitude and deborphan can help you to find out if a package is a dependency of another package:

$ aptitude why flashplugin-installer 
i   ubuntu-restricted-extras Depends    ubuntu-restricted-addons
i A ubuntu-restricted-addons Recommends flashplugin-installer

$ deborphan -a --ignore-suggests flashplugin-installer
flashplugin-installer:amd64 (contrib/web)
      ubuntu-restricted-addons:amd64

As you can see, flashplugin-installer is installed because ubuntu-restricted-addons recommends it:

$ apt-cache show ubuntu-restricted-addons | grep ^Recommends
Recommends: flashplugin-installer, gstreamer0.10-plugins-ugly, gstreamer1.0-plugins-ugly, gstreamer0.10-plugins-bad, gstreamer1.0-plugins-bad, gstreamer1.0-libav, gstreamer0.10-fluendo-mp3, gstreamer1.0-fluendo-mp3, chromium-codecs-ffmpeg-extra, oxideqt-codecs-extra

But wait, the recommended packages are automatically installed by default, but they're not mandatory. If you don't want Flash, just remove the package. Neither ubuntu-restricted-addons will complain nor you will break anything.

| improve this answer | |
  • 1
    Or at the time of installation with --no-install-recommends – heemayl Sep 7 '15 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy