0

First time I tried to install Ubuntu, I had some problems and I found out that the GPT table was corrupt. So, I fixed it, using the command sudo gdisk /dev/sda option w. Then I started the installation, but it suddenly stopped working, it was towards the end. Apparently, it is a bug in GRUB, the following information was given:

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: ubiquity 2.21.25 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CasperVersion: 1.360
Date: Sun Sep 6 00:17:48 2015
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed cdrom-detect/try-usb=true noprompt floppy.allowed_drive_mask=0 ignore_uuid boot=casper quiet splash ---
LiveMediaBuild: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
ProcEnviron:
 LANGUAGE=es_EC.UTF-8
 PATH=(custom, no user)
 LANG=es_EC.UTF-8
 SHELL=/bin/bash
SourcePackage: grub-installer
UpgradeStatus: No upgrade log present (probably fresh install)

How can I fix it ?

0

Your corrupt partition table must have had a cause, and that cause might be related to your subsequent problem of a failed GRUB installation. For instance, if the disk is failing, that could affect both the partition table and the GRUB installation; or if the partition table appeared to be damaged because of inconsistent RAID configurations across your OSes, that could also affect GRUB installation. Unfortunately, it's impossible to tell, given the information you've provided, what the cause of the partition table trouble was, so I can't offer any solutions that would be more than shots in the dark. It's also possible that these issues are unrelated -- for instance, some other tool might have damaged the partition table, and that would be unlikely to have any effect on a later GRUB installation. Thus, my first recommendation is to be aware of this issue and alert to future partition table troubles. If a problem recurs, get help. You might also run a SMART test on the disk, just as a precautionary measure.

I don't see anything in the information you posted that really helps diagnose your GRUB problem, so that's also a shot-in-the-dark sort of situation. I can, however, suggest a possible way to get moving again:

  1. Download the USB flash drive or CD-R version of my rEFInd boot manager.
  2. Prepare a boot medium from same.
  3. If you haven't done so already, disable Secure Boot on your computer.
  4. Boot to rEFInd. With any luck, it will show options to boot Ubuntu.
  5. Boot to Ubuntu using rEFInd. (If there are multiple Ubuntu boot options, try each one until one works or until you've exhausted all the options.)
  6. If you can get Ubuntu booted, you can proceed with further diagnostics and/or attempt to install a boot loader. You can try to manually install GRUB or install the rEFInd Debian package or PPA.

If you continue to have problems, post back with details. (Edit your original question or create a new one.) Cut-and-pasted error messages, or screen shots of the same, may be helpful. The output of sudo parted -l may also be helpful.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.