2

So I'm just coming back to Ubuntu after some time away, running 14.04 and I've gotten things customized the way I like them, more or less. At one point I'd attempted to download "Popcorn-Time." I ran into some issues of some sort and decided to remove it/that it wasn't worth the trouble.

Something from the install process seems to be "stuck" in apt-get though. I'm having issues getting new packages and I'm getting this message:

Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up popcorn-time (0.3.2~webupd8~6) ...
Downloading Popcorn Time...
--2015-09-06 11:25:00--  http://cdn.popcorntime.io/build/Popcorn-Time ...
Resolving cdn.popcorntime.io ...
Connecting to cdn.popcorntime.io (cdn.popcorntime.io)|45.33.69.37|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2015-09-06 11:25:00 ERROR 404: Not Found.

download failed
Popcorn Time is NOT installed.
dpkg: error processing package popcorn-time (--configure):
 subprocess installed post-installation script returned error exit status 1
...

Errors were encountered while processing:
 popcorn-time
E: Sub-process /usr/bin/dpkg returned an error code (1)

I've omitted a couple of lines there, but I think you get the idea. This is occurring when I try to install most packages using apt-get, maybe all packages. It seems like it's interfering, and frankly I'd like it to not try to install popcorn time every time I install any package.

Any ideas?

  • disable the popcorn webupd8 PPA and try again. – Ron Sep 6 '15 at 16:48
  • @Ron I tried that, no dice. See my comment on the answer below. Turned out I needed to remove it from dpkg's database. – MattB Sep 6 '15 at 23:47
3

Turned out I needed to remove it from dpkg:

dpkg -r popcorn-time

And that took care of it for me. Thanks again for the help and suggestions everyone!

| improve this answer | |
0

Since its site seems to be down try removing the popcorntime.io PPA: E.g. See this post

Then do an sudo apt-get update and apt should be ok.

| improve this answer | |
  • No dice. Still there. The remove command doesn't seem to work? sudo apt-add-repository --remove ppa:webupd8team/popcorntime produces the result Cannot add PPA: 'ppa:webupd8team/popcorntime'. Please check that the PPA name or format is correct. – MattB Sep 6 '15 at 23:34
  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. – David Foerster Sep 7 '15 at 20:42
  • @DavidFoerster Sorry, I don't understand your comment. – Hinz Sep 7 '15 at 21:33
  • 1
    @DavidFoerster This is an attempt to answer the question. – Seth Sep 7 '15 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.