1

After upgrading to 11.10 from 11.04, the Unity launcher shows a question mark icon for libreoffice-calc.

If I log in using Unity2D or log into the guest account (2D or 3D), the correct icon appears.

How do I associate the correct icon for my login?

3

Option 1

Save the file: http://en.wikipedia.org/wiki/File:LibreOffice_3.3.1_Calc_Icon.png

Later edit your ~/.local/share/applications/libreoffice-calc.desktop.

Find line with:

Icon=libreoffice-calc

And change it to your save file into:

Icon=*path-you-have-saved-it*

Option 2

Locate file icon in your system using search option. In my case it is like:

/usr/share/icons/Humanity/mimes/256/libreoffice-oasis-spreadsheet.svg

so your line should look like:

Icon=/usr/share/icons/Humanity/mimes/256/libreoffice-oasis-spreadsheet.svg
1
  • The second option you gave works great, I think it should be the first/only option. – AmanicA Nov 7 '11 at 16:00
0

Try removing it (right click > de-check "keep in launcher") then launch Calc from dash, and again right click > keep in launcher.

2
  • I tried that and unfortunately, it does not solve the problem. I also removed the application using the software center and re-installed, and that did not work either. – user27698 Oct 15 '11 at 22:51
  • Problem solved. I opened up the Main Menu app and set the icon there. – user27698 Oct 15 '11 at 23:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.