0

I'm an Ubuntu Newbie and I have an issue with the low display resolution of the Nvidia GeForce 9600 GT which i can't change. I'm using Ubuntu 14.04.

02:00.0 VGA compatible controller [0300]: NVIDIA Corporation G94 [GeForce 9600 GT] [10de:0622] (rev a1) Subsystem: CardExpert Technology Device [10b0:0401] Kernel driver in use: nvidia

I'm using the NVIDIA binary driver-version 340.76 and I think I have downloaded from the Nvidia's website.

What can I do?

Your support is more than welcome!

  • 1
    You need to add some info to get a helpful answer. Edit your question to include 1. Did you install Nvidia's drivers or are you using the ones standard with Ubuntu? 2. If you installes Nvidia's dirvers, how did you install them; via Ubuntu's "additional drivers" window or via the package you downloaded directly from Nvidia's website. – TrailRider Sep 6 '15 at 14:57
  • Which kernel driver you use? Enter the following: <pre><code>$ lspci -nnk | grep "VGA\|'Kern'\|3D\|Display" -A2 </code></pre> Please add the Output to your Question. – Arch User Sep 6 '15 at 15:37
  • I have the same GPU. Check my answer. – atilkan Sep 6 '15 at 16:55
0

Same issue: Second Screen Resolution Nvidia (Ubuntu 14.04 LTS)

Shortly

I declared a new display setting on Nvidia X Server Setting. And by saving it to correct place made it persistent after reboot.

-SOLUTION

  • Check if you have the right driver. It should be from Nvidia. See image.

check driver

  • Open Nvidia X Server Settings by searching computer or by terminal command below:

if installed:

sudo nvidia-settings

If it is not installed. Do this:

sudo apt-get install nvidia-settings
  • And choose X Server Display Configuration. It should look something like the image below.

enter image description here

  • Choose second screen, in my case it is CRT-1.
  • Open Configuration drop-down menu. Choose New X Screen. And Click Advanced at the bottom.

enter image description here

  • Then you should see Resolution settings inputs. Enter your Screen resolutions. It may come with like 1024x768. Change it to your need. I could not change ViewportOut. But we can Proceed.

enter image description here

  • Last part is saving those settings.

After entering your resolution there is a button at the bottom Save to X Configuration File .

Click it and save the file to this destination. /etc/X11/xorg.conf

  • Reboot and go to Settings > Diplays you will see more options at resolution drop-down.

enter image description here

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.