I recently updated Ubuntu to the latest 11.10 version. For some reason since the update Ubuntu reacts slowly. For example, when I drag a window there is a delay in the movement, when I write text it takes time for it to appear and more.

However, when I use GNOME Shell instead of Unity when I log in, the computer is as snappy as usual.

  • Try switch off V-Sync in OpenGL plugin and in nvidia-settings (if you use nvidia) – Extender Oct 16 '11 at 4:43
  • I switched them off and the delay is smaller, but still there is a delay that wasn't there in 11.04. Does 11.10 have higher hardware requirements? – eladrich Oct 16 '11 at 7:19
  • I don't think so; try change video driver (from opensource to proprietary or vice versa) – Extender Oct 17 '11 at 11:29
  • What driver did you end up using? I have the same issue and I am using the 3rd one down on the additional drivers. (version current)[Recommended] – Glenn Oct 18 '11 at 13:27

Problem solved.
I solved the problem by changing the graphics driver to version173-updates.
Hope that it helps others too.

  • 4
    can you describe the change you made in more detail? – david.libremone Oct 18 '11 at 13:27
  • @d3vid, he ran "Additional Drivers" and selected the "post-release" driver labeled "version173-updates". – Mike Pelley Oct 21 '11 at 15:03
  • i cahnged to each of them on HP DV6500 and nothing changes drastically. And Youtube- completely slow on fullscreen. Im putting back to 10.04 LTS – Kangarooo Mar 4 '12 at 22:10

Just finished dealing with this myself:

Disabling some plugins in the CompizConfig Settings Manager should fix this for you.

  1. Install the CompizConfig Settings Manager using the Ubuntu Software Center.
  2. Run the CompizConfig Settings Manager and un-checkmark anything you can.

Does that help?

  • 1
    Which plugins can I disable safely? – eladrich Oct 16 '11 at 7:09
  • Likely all of them. Maybe open each one up to see what it does, and decide whether or not you want that feature. Does that help? – fixedit Oct 17 '11 at 14:32

Gnome Shell can't display normally on my laptop, too. The panel bar just can't show the words clearly,and the CPU rates are higher than 11.04(sometimes a little bit too HIGH). I uninstalled unnecessary softwares and give up gnome shell. Lesser apps helps some in reducing CPU rates. Uninstalling gnome shell doesn't uninstall some apps the gnome shell affliciates. You can uninstall them manually via Synaptic or Software center. But do be careful. I uninstall the date-time indicator on the panel accidentally.

  • I installed 11.10 by flashdrive not through updating. And this time gnome shell displays normal. But Stellarium can't be opened normally in gnome shell but normal in Unity. And I can't close stellarium under gnome shell,too. Is anybody having the same problem? – Alex John Oct 29 '11 at 5:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.