Im having a bit of a problem with ubuntu. I just installed amd 11.9 driver from the amd website.

Now the boot is stuck at this image. boot fail

How do I resolve the issue without reinstalling Ubuntu? The computer is running Ubuntu 11.10 64bit with an a6-3400m CPU and a 6520g radeon card.

Thanks in advance.

  • can you access another tty? (press alt+ctrl+f1) – Bruno Pereira Oct 15 '11 at 19:52

I had all sorts of fun getting the 11.9 driver installed and working. Even using the "additional drivers" didn't work for me. I had the same issue you had as well. In the end I followed the following steps after booting into recovery and remounting, then dropping into netroot prompt:

1) Remove the fglrx and revert configuration:

    sudo sh /usr/share/ati/fglrx-uninstall.sh
    sudo apt-get remove --purge xorg-driver-fglrx fglrx*
    sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri
    sudo dpkg-reconfigure xserver-xorg

2) Follow the manual install guide:

    sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases
    sudo apt-get install ia32-libs (only if on amd64 as I was)
    sh ./ati-driver-installer-11-9-x86.x86_64.run (choose build deb packages)
    sudo dpkg -i fglrx*.deb
    sudo aticonfig --initial -f

3) Reboot.

  • That was overkill but it worked like a charm. Even gnome shell is working now (Other than horribly disfigured/skewed horizontal scroll bars and tooltips[sometimes]). Thank you very much. This is the reason I switched to ubuntu. =) – Roman Oct 16 '11 at 17:39

On my Ubuntu 11.10 (Lenovo g770), I couldn't start the X (LightDM). I tried Catalyst 12.1 drivers. I got some errors about /usr/lib64.

So, I created a symlink and it worked.

ln -s /usr/lib /usr/lib64


If you can access another terminal (press ctrl+alt+f1 keys) type sudo sh /usr/share/ati/fglrx-uninstall.sh.

That is the official driver remover from ATI, after that use the "Additional Drivers" application to install the ubuntu packages.

After you reboot to a clean desktop make sure all the old fglrx packages are gone:

sudo apt-get purge fglrx*

Remove your xorg.conf

sudo rm /etc/X11/xorg.conf

Reinstall xorg

sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64

Configure Xorg

sudo dpkg-reconfigure xserver-xorg


sudo reboot

After you get to your desktop again use the "Additional Drivers" program but don't enable the post update ones, use the previous version.

  • I ran the command and it did it's thing and I can access the gui fine. Thanks for that. However is there any way to install that driver? 11.9 specifically? I need it to run gnome shell properly. – Roman Oct 15 '11 at 20:16

There is issues with some ATI graphics cards using catalyst 11.9 and Ubuntu 11.10 - see the ubuntuforums thread here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.