5

Up until yesterday my default PDF viewer was evince. Today, I tried to open a PDF and it opened with ImageMagick. I am trying to change it back to evince but with no success. What I 've tried:

  • Changing it the standard GUI way from the file manager.
  • Editing ~/.local/share/applications/mimeapps.list
  • Deleting ~/.local/share/applications/mimeapps.list
  • $ xdg-mime default evince.desktop application/pdf
  • Tried with the Trusty version of Ubuntu Tweak (I am on 15.04)

I also checked the /usr/share/applications/mimeinfo.cache and /etc/gnome/defaults.list and both have evince.desktop as the first option.

As an extra note, changing other defaults works.

1 Answer 1

6

I have searched for all locations containing mime type associations and finally found the solution:

$ nano ~/.config/mimeapps.list

application/pdf was correctly set but image/pdf was set to ImageMagick. Edit it to your own preferences (evince.desktop in my case).

Checking if the PDF file is of application or image type was one of the first things I did (and it was application/pdf), so I suspect this is a bug.

1
  • The trick was ' image/pdf' needs to ve changed too. Commented May 26, 2023 at 1:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .