0

OK, how can i run this:

xrandr --output DVI-D-0 --mode 1920x1080 --rate 144

on startup?

OR:

Make nvidia-settings remember that I've set it to 144Hz and not 60Hz

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 355.06  (buildd@lgw01-22)  Mon Aug  3 21:32:29 UTC 2015

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Philips PHL 272G5"
    HorizSync       30.0 - 160.0
    VertRefresh     50.0 - 146.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 650"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "1920x1080_144 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
0

See the post here: wiki.ubuntu - xrandr, this shows you several ways to do it.

| improve this answer | |
0

You need to start nvidia-settings as root:

sudo nvidia-settings

Go to X Server Display Configuration

change the rate to 144 and click on Save to X Configuration File

Now it should be permanent.

How ever if you want to start your script, when you log on, then you could use ~/xinitrc to run your script.

If you don't want it, then you can use

system Menu > Preferences > Startup Applications

if you copy your script to ~/bin (because ~/bin is included in your $PATH environment), then you can enter the name, otherwise you must enter the full path.

| improve this answer | |
  • I deleted my xorg.conf file and made a blank one. Then I did that Save to X Configuration File thing but not as root, but then a password promp appeared. Did I do this right? – Kim André Sep 5 '15 at 16:52
  • Yes, but never delete config files, always back up them with mv configname configname_backup. If you have created the xorg.conf file, then open it nano /etc/X11/xorg.conf And search for Section Screen you should have the following option: Option "metamodes" "1920x1080_144 +0+0" – user447855 Sep 5 '15 at 16:55
  • The nvidia thingy didn't work; moving on to next thing... – Kim André Sep 5 '15 at 17:00
  • The startup Applications thingy doesn't work nether? – Kim André Sep 5 '15 at 17:04
  • Can you post your xorg.conf file? Did you gave your script executable rights? chmod +x scriptName – user447855 Sep 5 '15 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.