I have a Lenovo Thinkpad e540 laptop with dual graphics, Intel integrated and Nvidia GT 740m Discrete. After changing from nouveau drivers to Nvidia binary driver 346.82 proprietary before login screen I've got a message:

[0.646495]Error parsing PCC subspaces from PCCT
[0.646521]ACPI PCC probe failed.

Kernel version:

3.19.0-26-generic #28~14.04.1-Ubuntu SMP Wed Aug 12 14:09:17 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

I've read somewhere that if I put in grub file quiet splash nomodeset that will fix this, but that doesn't work for me, then I get into login loop.

How can I fix this?

  • I am having the same issue on a fresh install of Ubuntu 14.04. I have not knowingly changed any drivers. I am on a ThinkPad E550. – M1ke Sep 9 '15 at 8:49
  • Facing the same issue with Ubuntu 15.4 + 4.2 stable Kernel. I eventually get the login screen after the message is displayed 2-3 times. – Shehbaz Jaffer Sep 16 '15 at 0:50
  • 4
    Are you dual booting Windows and Linux? Because I've encountered something like this before in a friend's PC and the reason for this same error is Window's hiberboot which needed to be disabled. – Majal Jan 14 '16 at 11:13
  • @majal’s tip worked for me: Windows fast boot seems to have been the problem. After following instructions here, Ubuntu booted fine. – Jesse Glick Aug 18 '16 at 18:18
  • Also found askubuntu.com/a/702943/49860. – Jesse Glick Aug 18 '16 at 18:21

I had the same problem after installing Ubuntu 16.04 on the Lenovo w540 with preinstalled Win 8.1. It appeared that I didn't install Ubuntu with correct bootloader. The Windows was booting in UEFI mode while the Ubuntu in BIOS mode.So I've reinstalled Ubuntu, but this time I read:


  1. When I created a bootable USB key from the ISO image I made sure it will boot in UEFI mode = I used Rufus and chose 'GPR partition for UEFI' as a partition type for the bootable USB key (they say that there is a version of YUMI that support UEFI as well - didn't try it though )
  2. In my BIOS settings I've disallowed booting other than UEFI to make sure my USB key will boot with UEFI (I did the opposite of https://neosmart.net/wiki/enable-legacy-boot-mode/).
  3. The Ubuntu knew that it was booted from UEFI bootloader and it installed with UEFI bootloader as well.

The problem with the PCC parsing... didn't appear since then.

I don't know if it's relevant but I've installed Ubuntu on a separate drive with separate efi partition.In my BIOS settings I have now another entry on the boot order list: 'ubuntu'. It was placed by the Ubuntu installer on the first place so I moved it below the USB stuff but above the Windows Boot Manager so I can boot from USB key or choose from the GRUB2 boot menu which system to boot on each restart.


Due to the response on the comment, and that it apparently works...

Answer: Usually happens on Linux-Windows dual boot. Disable hiberboot (fast startup) in Windows. If it comes back after some upgrade, just boot to Windows and restart, worked on my friend's PC.

Windows > Control Panel > All Control Panel Items > Power Options > System Settings > Change settings that are currently unavailable (UAC) > Turn on fast startup (recommended) — unchecked this.

Note: Well, it really isn't recommended to dual boot Windows with Linux.


Windows 10 - http://www.tenforums.com/tutorials/4189-fast-startup-turn-off-windows-10-a.html

Windows 8 - http://www.trishtech.com/2013/07/how-to-disable-hiberboot-in-windows-8/


I've solved the problem on my lenovo thinkpad edge E540 by changing the nvidia driver used.

The Nvidia 340 generates the problem. With a driver more up to date, it works. First add the bumblebee package, then run the software updater of sudo apt update and new nvidia drivers become available. Select a more recent driver and let it install. You must then deactivate this package from the updates because it prevents Ubuntu from getting the updates of the xenial version.


I had this on Yoga 3 14 80JH

The bios upgrade and fix from lenovo support fix this. Unfortunately there is no ISO image to run bios update. You need to install Windows 10 to install patch and to flash bios.

  • This was exactly my issue on the ASUS Sage C651E motherboard.. There were many bios updates and updating corrected the PCC subspaces error – visc Jul 16 '18 at 14:07