2

I have a dual monitor setup, a laptop monitor and an external VGA monitor. The preferred mode should be 1920x1080 on laptop and 1600x900 on external monitor.

That's how it was but I installed (and then uninstalled) some nvidia drivers for other reasons. When I reinstalled the nouveau drivers the preferred modes on both monitors were 1024x768.

As you can see below on xrandr output the monitors have two preferred modes! Only that when using the --preferred flag it uses the undesirable 1024x768.

I am currently using a half fix by running on start up:

xrandr --output eDP1 --mode 1920x1080 --output VGA1 --mode 1600x900 --left-of eDP1 --primary

instead of running as before:

xrandr --output eDP1 --preferred --primary --output VGA1 --left-of eDP1 --preferred

The problem is that the display manager (slim) is still displayed on 1024x768 resolution and I have to log in for the preferred resolutions. Also in case I plug in a different monitor I would have to manually run xrandr with the correct resolution.

Is there a way to disable 1024x768 as a preferred resolution?

xrandr output http://pastebin.com/xuPEFMrH


Also, here is the xorg.conf in case it is needed: http://pastebin.com/8DemF0qi

I am not exactly certain how the xorg.conf regarding the monitors is interacting. I tried to change all 1024x768 to 1920x1080 but it didn't change anything.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.