4

I have been running Ubuntu Gnome 15.04 on my Thinkpad T420 for a couple months now, and so far it has been great. However, A couple days ago my "d"(lowercase only) key stopped working in any terminal application. Whenever I press "d", I just get the GNOME beep sound, and d won't be input. I can press Ctrl + V then "d", and that seems to work.

When I noticed this, I hit up some IRCs and was told to do this command:

bind -p | less

I did so, and the file was fine, for the most part. I found the listing for all the alphabet keys, and d was missing. it says this:

"a": self-insert
"b": self-insert
"c": self-insert
"e": self-insert

I proceeded to add d using

bind d:self-insert

and d started working in terminal again, however, whenever I close the terminal, it seems to forget this setting. I hate having to enter this command EVERY time I log in, and I would love to fix it. Any ideas?

EDIT: The contents of my /etc/inputrc file: http://pastebin.com/vnGy9n1i

  • Which package contains bind o_O – A.B. Sep 4 '15 at 6:06
  • @A.B., bind is a bash internal command. @Johan --- really puzzling. Have you installed something before the problem started? Otherwise you can try search all startup files for a "bind" command. – Rmano Sep 4 '15 at 10:33
  • Ah, bash. I'm using zsh =) – A.B. Sep 4 '15 at 10:48
  • edit your question and add the output of cat ~/.inputrc and cat /etc/inputrc – A.B. Sep 4 '15 at 13:06
  • 2
    Until you find a real answer to your problem, you can add the bind command to $HOME/.bashrc and it will be run whenever you open a shell (at least if you're using bash). It's likely that there are equivalent options for other shells. – Joe Sep 10 '15 at 9:20
0

You have probably set d as a keyboard shortcut for something. The likeliest culprit will be a shortcut set up in Preferences => Shortcuts of gnome-terminal. Make sure you haven't set D to something there.

If you are using xbindkeys, have a look at ~/.xbindkyesrc and remove the offending entry. Alternatively, check your desktop envoronment's keyboard shortcut settings and see if you've set anything up there (but I doubt that would cause the issue you describe).

Another possibility is that you have a bind command in your ~/.profile or ~/.bashrc (or any other shell setup file) files that disables the d. To test for that, try

grep --color -H bind ~/.bashrc ~/.profile ~/.bash_profile ~/bash.login \
                     ~/.bash_aliases /etc/bash.bashrc /etc/profile \
                     /etc/profile.d/* /etc/environment 2> /dev/null

If there is such a command, that should show it.

Finally, as a temporary workaround, just add this line to your ~/.profile (and not to ~/.bashrc):

bind d:self-insert

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.