I just installed 11.10. One of the standard things I do on a new install of Ubuntu is change the action taken when I hit the prtscn key. By default the action is to take a screenshot. I change it so that it takes a screenshot by area.

Here's how I do that in earlier versions: system>preferences>keyboard shortcuts Add Name: Take Area Screenshot Shortcut: gnome-screenshot -a Then click printscreen. It will ask you to disable the normal screenshot. Say yes.

Here's what I tried in 11.10 settings>keyboard>shortcuts go under custom shortcut Add Name: Take Area Screenshot Shortcut: gnome-screenshot -a All seems good so far. I see a new row that shows disabled. That makes sense to me because I haven't yet assigned a key to it. But here's where I get hung up. If i click the prtscn it actually takes a screenshot. If I hold prtscn down for 3 seconds, my computer gets bogged down and when it finally recovers I have to cancel over 20 screenshots that it has taken. So I figured the problem is that I first need to disable the default screenshot shortcut. So I went there and click backspace, but no go.

Any suggestions?

  • ok. I just made progress but still haven't solved the problem. Here's how you set the shortcut for the action once you have created it. First select the row, then click the word "disabled" (this part is unintuitive--at least for me). Once you click "disabled" it changes to "New Shortcut..." When those words show up click the print screen key once. You are asked to confirm and then bingo. The new action is assigned to the print screen key. HOWEVER, it still doesn't actually work. Now I hit the PrtScn key and nothing happens.
    – snowguy
    Commented Oct 15, 2011 at 18:11

3 Answers 3


For future reference, in 12.04 you can use Shift+PrtScn to capture area.

  • 2
    Still works in 16.04!
    – Lisa
    Commented Jul 5, 2017 at 16:04

At this point I am convinced there is a bug such that you cannot actually connect the print screen button (prtScn) to any custom shortcut. The key works fine if you leave it as the default, but assign it to something else and it is wortheless. The best workaround I believe is to assign it to a different key instead. Other key combinations tend to work. I used the combination of ctrl + prtscn.

Here are the instructions: Open System Settings click once on "keyboard" Go to the "shortcuts" tab Click "Custom shortcuts" from the list of items on the left Click the plus icon near the bottom of the windows. Fill the name box in "Print Screen by Area" Fill in the comand box "gnome-screenshot -a"

No you'll see the word "disabled" to the right of your new shortcut. Click on the word "disabled" Click again on the word "disabled" and it should change to "New Shortcut" Press ctrl + PrtScn and the word "disabled" will change to "Ctrl+Print" You are done. You can close the system settings window.


If you use compiz/unity3d then you can use compizconfig-settings-manager and the Gnome Compatibility plugin, and just swap them around.

  • Thanks. I didn't install compiz. If it turns out that is the only solution, maybe I'll go there.
    – snowguy
    Commented Oct 15, 2011 at 18:05
  • I have just tried the way you tried with keyboard shortcuts tool (I had to use unity2d first) and it worked ok. Odd
    – duffydack
    Commented Oct 15, 2011 at 18:16
  • So were you able to use the prtscn button to take a print screen by area? After doing the steps above everything looks like it should work...it all seems setup right. BUT, when I hit the PrtScn key nothing actually happens.
    – snowguy
    Commented Oct 15, 2011 at 18:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .