Trying to build an nginx server with Phusion Passenger on Ubuntu 11.10 (hurray for the new version!). Running "passenger-install-nginx-module" outputs the following error:

* OpenSSL support for Ruby... not found

With the following suggestion to fix it:

* To install OpenSSL support for Ruby:
  Please run apt-get install libopenssl-ruby as root.

Running "sudo apt-get install libopenssl-ruby" yields the following output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libruby' instead of 'libopenssl-ruby'
libruby is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

A little research shows that libruby is a virtual package that provides libopenssl-ruby as part of the package. However, the passenger-install-nginx-module script still can't find it, and keeps throwing the same error. Help me, please! I'm in a little over my head on this one, and the google-the-error-code method that usually works is failing me today.

  • I'll try to confirm this, I'm upgrading my Rails server to 11.10 later today. – jrg Oct 15 '11 at 16:21
  • OK, I can't replicate this. :( – jrg Oct 18 '11 at 12:18

You need to change to your ruby ext/openssl/ directory, then run

ruby extconf.rb 
make install

then try passenger-install-nginx-module again

| improve this answer | |
  • Thanks for the tip. My computer has died in the interim, so I'm waiting for the replacement to arrive. I'll test this out when it gets in. – flintinatux Oct 22 '11 at 16:35
  • @flintinatux did you get the chance to test it again? – jrg Jan 10 '12 at 22:43
  • Had the same problem as the asker, but with the Blather gem. Tried your instructions but extconf.rb didn't work ("Makefile wasn't created"). I found a forum post that helped - ruby-forum.com/topic/99825 - and now these instructions work. – iftheshoefritz Apr 11 '12 at 21:00

No. I got so mad at Ubuntu that I switched to Windows 7. I realized that I was spending more time setting up tools than I was actually producing code. I've since moved on to other projects, and still only use Windows 7.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.