I've installed the ati catalyst drivers 11.9 manually because the default ones don't work with gnome-shell. But when that I try to change the settings in amdcccle(adminstrative) to use multi-display, the application closes and doesn't change anything or asks me to confirm and still doesn't save at all.

This is my xorg.conf http://pastebin.com/P5XmNKfM How can I fix this?

  • same here. Tried wiki.cchtml.com/index.php/… This helped installing the driver, but the config does not save and when I change something, I am thrown to the login screen on the screen I configured as 2nd monitor. After loging in again, display switches back to the original monitor and the 2nd is black. Opening amdcccle again tells me only the first monitor enabled. This is a better behaviour as with the ubuntu shipped driver, but does not help anything. – user27652 Oct 15 '11 at 18:19

The steps that (eventually) worked for me on 11.10 (Oneiric) with a 1680x1050 22" and 1024x1280 19" (counter-clockwise ;)):

[Skip to important/troublesome steps in bold]

  1. Install the "ATI/AMD proprietary FGLRX graphics driver" (the "post-release updates" version failed for me)
  2. Reboot and see the horrible mirrorring at low res
  3. Use amdcccle(adminstrative) (after experiencing the horrible crashing of this question), and
    1. Disable the second monitor
    2. Apply
    3. Re-enable the monitors with all the settings that you want
    4. Apply/OK etc
  4. Log-off and on and see if it sticks: if it doesn't (it didn't for me)

    1. Redo 3
    2. Go to the normal display settings control panel and save (I don't think this is necessary, but it's what I did)
    3. Open Terminal and

      cd /etc/X11
      sudo mv xorg.conf.ati xorg.conf.ati.bak
      sudo cp xorg.conf xorg.conf.ati

      Your settings should stick now.

I would think that simply doing step 3 then sudo rm /etc/X11/xorg.conf.ati would work, but I'm not about to mess it up :).


Probably a silly question, but are you running amdcccle as root?

If you're already doing that, maybe I can still help. Here's what I've got:

Graphics card: AMD Radeon HD 6670 (vendor: ATI Technologies Inc)

OS: up-to-date Ubuntu 11.10

I'm using the ATI proprietary driver(s) right now. The open source drivers were working for a while, but my desktop broke with a recent upgrade, so I switched to the dark side.

Here are the basic steps I followed:

mkdir catalyst && cd catalyst
wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-9-x86.x86_64.run
sh ./ati-driver-installer-11-9-x86.x86_64.run --buildpkg Ubuntu/oneiric
sudo dpkg -i fglrx*.deb
sudo aticonfig --initial -f

Once I rebooted, I had to do this to configure the dual-head setup:

sudo amdcccle

Note that sometimes amdcccle crashes, but it still seems to set up the dual-head properly. I have to re-run amdcccle every reboot for some reason. Luckily I don't reboot often, and when I do rebooting is pretty fast.

Anyway, you've probably done something similar to install the AMD/ATI catalyst driver(s). The steps are generic and covered in multiple tutorials.

My xorg.conf looks very similar to yours. I've got a dual head too, but one of them is rotated to be a tall/portrait monitor.

Not the answer you're looking for? Browse other questions tagged or ask your own question.