4

How can I enable raw mouse input in 14.04. That is

No modifications on acceleration. No change regarding movement speed. Therefore the DPI/CPI of the mouse should correspond to the amount of pixels the cursor will move when the mouse is moved one inch.

This is the output of xinput:

$ xinput
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech G400s Optical Gaming Mouse       id=8    [slave  pointer  (2)]
⎜   ↳ HID 046a:010d                             id=10   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ HID 046a:010d                             id=9    [slave  keyboard (3)]
3
  • Please edit your question and add output of xinput terminal command. – Pilot6 Sep 3 '15 at 18:47
  • Which mouse are you asking about? Logitech or the other one? – Pilot6 Sep 8 '15 at 15:13
  • Logitech. I don't know what the other entry is, cause I actually never used a different one. – Christian Sep 14 '15 at 18:35
5
+50

You can disable mouse acceleration this way.

Create a file /usr/share/X11/xorg.conf.d/50-disable-mouse-accel.conf with this content

Section "InputClass"
    Identifier "My Mouse"
    MatchIsPointer "yes"
    Option "AccelerationProfile" "-1"
    Option "AccelerationScheme" "none"
    Option "AccelSpeed" "-1"
EndSection

and restart session.

2
  • What do i write in "My Mouse" ? – Umar Oct 23 '15 at 13:46
  • Leave it as it is. – Pilot6 Oct 23 '15 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.