3

Whenever I hide files (Ctrl-H), when I start up Nautilus again the previously hidden files will show up again. I'm using Gnome. I don't seem to have a menu -> preferences like other postings state.

Solution: In Gnome: Click on the title for Nautilus in the task bar and then on settings. Inside is a setting to hide files permanently.

enter image description here

  • What file are you trying to hide and what are you doing to hide them? – TellMeWhy Sep 3 '15 at 18:16
  • Ctrl-H, I guess this are system files. – empedokles Sep 3 '15 at 18:19
1

Your method is fine, but you need to permanently change the view.

Go to Edit > Preferences > Views and turn off Show hidden and backup files.

That should do it.

  • Only until I close Nautilus. Is it a bug? – empedokles Sep 3 '15 at 18:27
  • @empedokles New edit – TellMeWhy Sep 3 '15 at 18:28
  • Nautilus has no written menu structure in Gnome. – empedokles Sep 3 '15 at 18:43
  • 1
    @empedokles right-click the tab of the program, where in other environments you can select minimise, close, etc. - from there select Preferences – TellMeWhy Sep 3 '15 at 19:13
  • 1
    @empedokles - now select Preferences (guessing 'Einstellungen' in German), and in the Views tabs you should have the option for it - make sure it is off. To turn it on/off temporarily press 'Ctrl'+'H' or enable/disable hidden stuff in the View menu (downward triangle button). – Wilf Sep 3 '15 at 20:06
2

The standard way to hide files on Linux/Unix is to add a leading dot into the filename. Typically it's done in command line but you can do it through nautilus as well

  1. Click on the file
  2. Click F2
  3. Add a leading dot in the filename. For example , rename myStory.txt to .myStory.txt
  4. Refresh with F5 key; your file will be hiddne now.
  • 3
    Just a suggestion, but I think OP means already existing dot files are showing up when nautilus starts rather than how to create a hidden file. If nautilus menu no longer has a setting for this, he needs to use dconf-editor. – chaskes Sep 3 '15 at 18:24
  • My problem is that .files are being shown. There is a setting to hide, but if I close Nautilus and restart the files are shown again. – empedokles Sep 3 '15 at 18:24
  • @empedokles OK, that clarifies things. Can you please run this gsettings list-recursively | grep 'nautilus' | grep 'hidden' in terminal and let me know what it says. Also, are you on Ubuntu 15.04 ? – Sergiy Kolodyazhnyy Sep 3 '15 at 18:28
  • Ok, you have 15.04 tag, I see. – Sergiy Kolodyazhnyy Sep 3 '15 at 18:29
  • @Serg : nuc@nuc:~$ gsettings list-recursively | grep 'nautilus' | grep 'hidden' org.gnome.nautilus.preferences show-hidden-files false org.gnome.nautilus.preferences show-hidden-files false – empedokles Sep 3 '15 at 18:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.