1

After the last update of Ubuntu sudo apt-get update Firefox won't start anymore.

It always show crash error on startup and i tried to reinstall it and change profile and even purge installation. It always crashes. I don't know what to do, here is a crash error that i get.

Add-ons: ubufox%40ubuntu.com:3.1,%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:40.0.3
BuildID: 20150826185918
CrashTime: 1441291808
EMCheckCompatibility: true
FramePoisonBase: 7ffffffff0dea000
FramePoisonSize: 4096
InstallTime: 1440756382
Notes: OpenGL: NVIDIA Corporation -- GeForce GTS 250/PCIe/SSE2 -- 3.3.0 NVIDIA 340.76 -- texture_from_pixmap

ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
ProductName: Firefox
ReleaseChannel: release
SecondsSinceLastCrash: 75
StartupTime: 1441291807
TelemetryEnvironment: {"build":{"applicationId":"{ec8030f7-c20a-464f-9b0e-13a3a9e97384}","applicationName":"Firefox","architecture":"x86-64","buildId":"20150826185918","version":"40.0.3","vendor":"Mozilla","platformVersion":"40.0.3","xpcomAbi":"x86_64-gcc3","hotfixVersion":null},"partner":{"distributionId":null,"distributionVersion":null,"partnerId":null,"distributor":null,"distributorChannel":null,"partnerNames":[]},"system":{"memoryMB":3953,"cpu":{"count":2,"vendor":null,"family":null,"model":null,"stepping":null,"extensions":["hasMMX","hasSSE","hasSSE2","hasSSE3"]},"os":{"name":"Linux","version":"3.16.0-37-generic","locale":"en-US"},"hdd":{"profile":{"model":null,"revision":null},"binary":{"model":null,"revision":null},"system":{"model":null,"revision":null}},"gfx":{"D2DEnabled":null,"DWriteEnabled":null,"adapters":[{"description":"NVIDIA Corporation -- GeForce GTS 250/PCIe/SSE2","vendorID":"NVIDIA Corporation","deviceID":"GeForce GTS 250/PCIe/SSE2","subsysID":null,"RAM":null,"driver":null,"driverVersion":"3.3.0 NVIDIA 340.76","driverDate":null,"GPUActive":true}]}},"settings":{"blocklistEnabled":true,"isDefaultBrowser":true,"e10sEnabled":false,"telemetryEnabled":false,"locale":"en-US","update":  {"channel":"release","enabled":true,"autoDownload":true},"userPrefs":   {}},"profile":{}}
Theme: classic/1.0
Throttleable: 1
Vendor: Mozilla
Version: 40.0.3
useragent_locale: chrome://global/locale/intl.properties

This report also contains technical information about the state of the application when it crashed.

Can it be something about nvidia drivers update maybe?

EDIT: I searched for --texture_from_pixmap on Google about crash and it come up with some answers but nothing correctly how to fix Firefox, but it has something that i noticed last time i opened Firefox and it was working. When i searched on Google about error the forums explained something about bad characters, and last time i noticed when i opened Firefox on one website where it was some strange characters instead of arrows characters left and right.

EDIT #2: Now even Thunderbird is crashing after some time. I reinstalled Nvidia drivers and even installed different version. But the one thing that i tried is logout of my account and than login on Guest account and on Guest account Firefox is working, it started normally and i surfed a while and everything is ok. Back on my account again Firefox crash on start.

2

I ran into the same problem, after updating yesterday morning. I solved my problem by removing the pepper flash wrapper from chrome called freshplayerplugin. sudo apt-get purge freshplayerplugin

1

https://github.com/i-rinat/freshplayerplugin/issues/261

Apparently the actual problem is just a line in the config file for FreshPlayer found in: /home/'your-username'/.config/.freshwrapper.conf

Change the line that starts with "flash_command_line..." to "#flash_command_line..." or delete the line entirely.

This will allow FreshPlayer (and Firefox) to work normally without any loss of functionality. The author of FreshPlayer says that config line doesn't do anything anyhow.

I tried it and Firefox and FreshPlayer were both back to working normally again.

Thanks for your help, Alesksandar. I would never have fixed this on my own.

  • Thanks Tim, i didn't looked at freshplayerplugin git for an answers, after i found out where is problem i was just glad to disable plugin and have my Firefox working again. But by removing this line you mentioned in config i can use plugin again and everything is working as it was before. – Aleksandar Đorđević Sep 5 '15 at 17:10
0

Open a terminal and type firefox --help for some insight.

Among the text shown by that you will see:
--safe-mode Disables extensions and themes for this session.

So, this might be some help to get further:
firefox --safe-mode

... I'd expect it to display an option to reset the settings/plugins
(you should not lose links or bookmarks by this).

  • Nope, i always get the same error, i tried to create new profile with starting with --ProfileManager, it opens profile selector and i create new profile but when starting i get the error, and also in --safe-mode too, the error is there again on startup, i will search to see if -- texture_from_pixmap in error have something to do with crash. – Aleksandar Đorđević Sep 3 '15 at 15:57
  • For what it is worth, I also experienced some trouble... currently I have started a new profile, using firefox --ProfileManager - I had my bookmarks saved so could restore those, restored the remainder manually. Seems to run now. – Hannu Sep 3 '15 at 20:32
  • I just got back home 10 min ago and trying to figure out a problem. Reinstalled Firefox completely again used --purge and also autoremove. Installed firefox tried to run with new profile, and before that i checked that everything is removed from .mozilla folder and still nothing. I will reinstall Nvidia drivers now and see if that will do anything. – Aleksandar Đorđević Sep 3 '15 at 20:37
0

Alright looks like i found the problem, the problem was with flash player plugin. For some reason looks like update of flash player is causing Mozilla (not only Firefox, Thunderbird too) to crash. After i deleted /usr/lib/mozilla/plugins folder, Firefox started, i copied back my bookmarks and history and everything is back to normal. Looks like videos with html5 player are working but flash not.

EDIT: As i checked further in my backups, i had installed Pepper Flash plugin previously, so that's what it was causing the problem. I have removed it and now it works. Although apps that require newer flash player don't work now.

0

Thank you! After having worked most of 24h incl. half of the night desparately, because I needed to set up a spare PC with, guess what, firefox and thunderbird for banking, news and e-mails, deleting the plugins directory at /usr/lib/mozilla was the solution (I strongly advice, however, not to delete, but to rename it (something like mv ./plugins ./plugins-dangerous - not tried to enter this actually, see last paragraph, as I re-installed xubuntu 16.04 later - )). Had tried xubuntu and ubuntu 16.04, and then ubuntu 14.04. Firefox 45 and 50 as well as thunderbird did run perfectly from live DVD, any ubuntu version, but never after (clean and new) installation on HDD.

It had not helped at all to start firefox with firefox --safe-mode!

Edit: crazy! As my last installation was ubuntu 14.04, I did another clean install of ubuntu 16.04 from the same DVD I burnt before, but this time did not enable my WiFi while Ubuntu was running from live DVD. So, no content besides what was on xubuntu-16.04-desktop-386.iso could be installed. This time, after the installation on HDD finished and I entered my password for WiFi, firefox 45.0.2 and thunderbird started fine - there even does not exist a file /usr/lib/mozilla/plugins. I will be damned if I ever update Firefox and Thunderbird ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.