45

I had installed VLC media player from the Ubuntu Software Center recently. It worked for some time, but then instead of the video, only a blank screen was displayed with the audio. Even the same videos that could be played before did not work.

I tried uninstalling and re-installing, and I upgraded it to the latest.

I've tried: menu ToolPreferencesVideo → enabling Accelerated video output (Overlay).

Execution via the terminal also gives the same.

I'm using Ubuntu 14.04 (Trusty Tahr).

1
  • uncheck accelerated video output
    – Ravan
    Commented Sep 3, 2015 at 13:42

15 Answers 15

67
    • Go to ToolsPreferencesVideo
    • Remove the tick for Accelerated video output (Overlay)
    • Try and play the movie again, you should now see output.

Or

2.

  • Go to ToolsPreferences->Video
  • Change Output to X11 Video output

If the above doesn't work, that particular video might have a proprietary video format that is not supported.

Reference here.

7
  • 16
    #2 worked for me, on Ubuntu 17.04. Output defaulted to Auto, but specifying X11 fixed it.
    – Johann
    Commented Aug 31, 2017 at 0:12
  • #2 worked for me as well, on 17.04. Weird
    – ffflabs
    Commented Nov 1, 2017 at 0:58
  • X11 fixed it. Shouldn't this be reported as a bug? Commented Dec 4, 2017 at 3:37
  • 2. worked for me, on Xubuntu 16.04 Commented Feb 14, 2018 at 18:07
  • @LonnieBest that might be a feature that we don't have any idea about. anyway x11 worked for me, Commented Aug 17, 2018 at 17:08
10

My workaround is to delete the VLC config-file. Open a terminal in ~/.config/vlc and

rm vlc-qt-interface.conf

Weird thing, if i delete the config file with Nautilus filemanager: still no window.

2
  • This worked for me!
    – krishna
    Commented Oct 20, 2017 at 15:50
  • Worked for me too. thanks!
    – DAB
    Commented Nov 20, 2022 at 21:16
8

Also, This happend to me, but...

navigate to:

: menu Tool → Preferences → Video

Check the output drop-down menu

and check that you have chosen the appropriate output codec, It was set to "auto" in the drop-down and needed to be selected "X11"

5

I'm using Ubuntu 16.04 and updated to vlc 2.2.7. I had the same problem after updating the update.

Go to Tools -> Preferences -> Video -> Output and select any of the first three options that end in (XCB). This resolved the issue for me.

janitor-
enter image description here

You can also try either of the OpenGL options and they also work.

1
  • This fixed it for me after I upgraded to 20.04 --I still need to upgrade again to 22.04. I'd like to add that as far as I can tell you should always run VLC from the command line without options. Running it from the desktop icon seems to make it accumulate settings changes until it won't work. Then deleting everything in ~/.config/vlc as suggested by JvdH is the solution.
    – Wastrel
    Commented Oct 7, 2023 at 0:08
1

I've noticed this problem for a couple of years now, and have noticed this pattern and work-around:

  • If VLC is minimized when it's called to play a file, the video will fail: it will show as blank/black.
  • If VLC is not minimized when it's called to play a file, the video works just fine.

The workaround is to make sure VLC is not minimized when you feed it a file to play.

How I found this out: I have a playlist file on the desktop. I typically press the "Show Desktop" button to minimize all windows before I run that playlist file. If VLC was already opened, it is now minimized. If I then open the playlist file, the VLC windows will pop back up, but the video will fail.

However, if I make sure to bring VLC back to its windowed state before opening the playlist file, the video works.

1

If the VLC still play without video the problem can be due to the incompatible video codec contained in the files. In this case, maybe need to convert the file to VLC more supported video format. You can choose Makemkv or Pavtube video converter,both powerful video tools.

1

Easy fix and no u don't need to listen to the above. Go into VLC and go to bottom right where the 3 dots are located and go to settings. Then go to video settings and turn off hardware decoding. Problem solved

1

I had the same issue on Ubuntu 22.10 Wayland VLC 3.0.17.4. When I purged the application, it worked exactly one time. When the vlc was launched for the second time, the video remained blank, however any snapshot taken worked.

It turned out, deleting the geometry line from ~/.config/vlc/vlc-qt-interface.conf helped. geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x3\0\0\0\0\0\0\0\0\0\0\0\0\a\x7f\0\0\x4\x37\0\0\x2\x80\0\0\0@\0\0\a\x7f\0\0\x2\xcf\0\0\0\x1\x2\0\0\0\a\x80\0\0\0\0\0\0\0%\0\0\a\x7f\0\0\x4\x37)

However, it got recreated every vlc launch. I changed the screen size on the blank video window by mouse and re-launched. It works now.

May this strange advice help some future visitors of this old issue.

1
  • I tested this on Kubuntu 22.04 with VLC 3.0.17.4 and it fixes the issue. The above suggestions didn't. Unfortunately the geometry=... line from the [general] section has to be removed before every start.
    – zx485
    Commented May 4, 2023 at 22:10
0

I had the same problem with fresh install of Ubuntu 16.04 and fresh VLC. My video card is NVidia and I was using the binary proprietary driver version 361.42 I switched to version 340.96 of the same driver and I got the video running without any problems.

Hope I helped.

0

This happened to me when I accidentally deleted libavcodec (probably it was targeted by apt-get autoremove after deleting some other package). In my case no player (I tried vlc, xplayer, smplayer) except browsers were not able to play any video (I tried for mp4, avi, mkv) but the audio worked. Re-installing this package fixed my problem. So check if it's installed.

0

None of these worked for me, but a "mark for reinstall" in synaptic did the trick.

0

In my case (Kubuntu 18.10 x64) changing Output to X11 Video output (as Ravan proposed) did not help, but XVideo output (XCB) helped.

So...

  • Go to ToolsPreferences->Video;
  • Change Output to XVideo output (XCB).
0

After trying (almost) all suggested solutions above, I found a workaround to this VLC bug:
Deselect

ToolsPreferences->Interface->Appearance->Adjust interface to video size

This is a solution similar to the "removing geometry=@ByteArray..." approach.

-1

You can try this too (I did it in Ubuntu 16.04.03)

uninstall VLC at all, then open terminal window and type:

sudo add-apt-repository ppa:videolan/master-daily

then:

sudo apt-get update

and then:

sudo apt-get install vlc

it works for me, so I hope you can get it too.

-2

Resetting preferences helped me

Tools -> Preferences -> Reset Preferences

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .