-1

Hi computer geeks and nerds, i am in no way a computer guru. My sony viao S series laptop decided to break after just a year. My hard drive failed meaning it held all my work and files including 5year uni work that i hadnt backed up. so i created a live CD using ubuntu.

After a long attempt to get it to load on my computer it finally did. In the ubuntu disk usage analyser i see my files size in 'gb' but i am unable to drag them into my USB for backing up.

When i try to drag it says i have no permission to do so (root owned the folders).

Next i added a new account which is myself as administrator but this only logged me out and asked for password which i never had to begin with.

My weak laptop was on for hours trying to figure this out so i had to shut it down direct from the ubuntu desktop to preserve its life.

please advice what do i do now?.

What is the best option to get my files from my hard drive without further damage to my hard drive etc. Also i tried a bunch of several commands and terminals i found online before then adding new user account none of which worked.

PLEASE help!. I will be keeping a close eye in the next 30mins. Please help me.

Thankyou

0

Hold CTRL+Alt then hit T
A Terminal window should open, and you will see a $-prompt where you may type commands.

Type sudo -i nautilus & and hit Enter

This should open "Files" (Ubuntu default file manager) and allow to read (and possibly write to) your old HD.


If that does not work, then your most viable option is using "Testdisk" which is described here

Please read the entrie posting, and note that the actual instruction begin at
Boot your Ubuntu LiveCD ("Try Ubuntu")

Note that you also have special sections later in the answer that helps in using file-copy type recovery - that starts at:
Copy data from the live system to an external drive ... which adds to what is above, at the beginning of this answer.

22
  • Thankyou. The problem is my Hard Drive wasnt coming up. Nothing was coming up. Also operating system was not found before i boot the live cd into my laptop. Also, whenever i try to type commands it says the file directory does not exist. – Help-please Sep 3 '15 at 13:51
  • Use this from the Live CD! I interpreted the text in your question to say that you can access the files from the Live CD. – Hannu Sep 3 '15 at 13:52
  • Is that 1 or i next to the command 'sudo nautilus?. Also i believe i already tried this command it tell me that the file directory was incorrect Or not found also i tried them with space and also joined together. Please excuse the naivity i dont know much about computers. – Help-please Sep 3 '15 at 13:58
  • That is a lower case i, not a number. If this doesn't work, then you will probably need file recovery tools. – Hannu Sep 3 '15 at 14:00
  • Yes of course the live CD was on when i tried doing this. Otherwise i wouldnt be able to getinto my laptop any other way as the only option before live CD was bios which didnt bring files up either – Help-please Sep 3 '15 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.