I have a 3200x1800 ultrabook and I would like to decrease the resolution of the screen 2x. The problem is that once I do it all the GUI elements increase in size too much

enter image description here

Is there a way how to scale down the size of everything that Gnome Shell shows ?

  • What do you mean by decrease resolution ? You used a 1080p resolution ? – hg8 Sep 3 '15 at 8:34
  • sorry for not being precise ... by the decrease I mean from 3200x1800 to 1920x1080 – dawe134 Sep 3 '15 at 9:34

Your best bet is to keep the 3200x1800 resolution and just change the interface scaling factor of GNOME.

Command line method:

Open a terminal (Ctrl+Alt+T) and execute :

gsettings set org.gnome.desktop.interface scaling-factor 2

You can reset this setting later by running :

gsettings reset org.gnome.desktop.interface scaling-factor

Graphical method:

You can use the gnome-tweak-tool:

sudo apt-get install gnome-tweak-tool 

Go to "Windows" and set "Window Scaling" to 2:

gnome-tweak-tool screenshot
Credit to PCWorld for the screenshot

  • 2
    Thanks, it seems that this fixes the issue to some extent on my primary builtin 3200x1800 display. However, once I connect a secondary one which has a native resolution of 1920x1080 the secondary display shows the same issue. Setting the scaling factor to a lower value doesnt really improve the situation. – dawe134 Sep 3 '15 at 9:46
  • 1
    Screenshot of the current situation. The right part is the external display, the left is the builtin ultrabook display. – dawe134 Sep 3 '15 at 9:53
  • 1
    THANKS! Although I have the gnome screen scaling bug the thread seems like a great resource. – dawe134 Sep 7 '15 at 15:31
  • 1
    Neither of these options work on Ubuntu 17.10, in Gnome-Tweak-Tools there is no "Window scaling" option on this page (but others like in the above screenshot). – Thomas S. Nov 9 '17 at 8:11
  • 1
    On my Ubuntu 17.10 I tried doing gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']" but it didn't add any settings. I didn't have an HDPI section in the tweak tool. The only thing that worked was gsettings set org.gnome.desktop.interface scaling-factor 2 after logging out and logging back in. Scaling-factor can only take integers – Alexander Nov 15 '17 at 2:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.