The Short Story

Asus X205TA, 32bit grub, 64bit Ubuntu 15.04, kernel 4.0.5-generic

Problem: Partially installed grub-efi-amd64-signed causes error messages.

Question: What should be done about that?

The Long Story

I installed Ubuntu 14.10 on my X205TA following these instructions. However, I did leave Windows 8.1 intact and successfully set up dual-boot instead of deleting it.

After successfully installing Ubuntu I set up wifi and the SD-card reader following this Debian wiki page. In the process I installed the 4.0.5-generic kernel downloaded from the Ubuntu Kernel Team server.

Everything worked - except sound and bluetooth. Which is okay with me.

I then upgraded to Ubuntu 15.04 using

sudo do-release-update

The update worked, but reported that it failed to install grub-efi-amd64-signed.

sudo reboot

then resulted in a freeze at the Ubuntu loading screen. Ctr-Alt-F2 did not work. I pressed the power button to turn off the device and then immediately turned it on again. I selected the 3.19 kernel and Ubuntu booted. Booting after that worked with the 4.0.5 kernel as well.

Now sudo apt-get upgrade produces

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... The following packages were automatically installed and are no longer required:
  gcc-4.9-base:i386 linux-headers-3.16.0-23 linux-headers-3.16.0-23-generic
  linux-image-3.16.0-23-generic linux-image-extra-3.16.0-23-generic
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up grub-efi-amd64-signed (1.46.1+2.02~beta2-22ubuntu1.1) ...
grub-install: error: /usr/lib/grub/i386-pc/modinfo.sh doesn't exist. Please specify --target or --directory.
dpkg: error processing package grub-efi-amd64-signed (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Apart from this error message nothing has changed after the upgrade, except that my brightness setting is now remembered after reboots and that suspend does not work any more.

The question is:

What should I do about this error? Can it safely be ignored (32bit grub works just fine)? Or should I remove grub-efi-amd64-signed? Re-install it? And why do I even have it installed - the X205TA only supports 32bit EFI after all.


I've been getting this error when installing from scratch. I was attempting to overwrite my old partitions, and let the installer handle it automatically by selecting "Erase Ubuntu and reinstall" (at least, I think that's what it said). It would error out at trying to install grub2. I resolved it by selecting "something else" on install, and specifying to format my Ubuntu partition. At that point, it worked without a hitch.

I think this is because the EFI partition gets corrupted in some way. You could try running dosfsck on the EFI partition. At least, that's what this bug report says: https://bugs.launchpad.net/ubuntu/+source/grub-installer/+bug/1434871

I do not know if you can ignore the error. It left my system in an unbootable state, though, so I'd certainly be careful with it. If you are able to boot without a problem, then it's probably just going to cause errors when you try to update until this is repaired.

  • Thanks for your answer. The problem was that the Ubuntu installer attempted to install 64bit grub on a 32bit system. That is obviously not going to work. When installing from scratch you would have had to manually install 32bit grub after completing the installation and getting the error. In my case I could still boot because I already had 32bit grub installed, just the older version from my original install. – user446066 Jul 4 '17 at 10:12
  • I ultimately just removed grub-efi-amd64-signed and nothing happened except the errors were gone. – user446066 Jul 4 '17 at 10:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.