4

When I play audio files with the default application (totem), nothing can be heard (but the "disco effect" animations are active). Sound is not muted in totem and in fact is pushed up to the fullest. Opening the same sound file in audacity and playing it there works. There doesn't seem to be any place in totem where I could have misconfigured something. What could be wrong?

EDIT: The problem is apparently not related to audio file type. All the following files can be played from within audacity for example and are mute in totem:

$ file test*
test.aac: MPEG ADTS, AAC, v4 LC, 44.1 kHz, stereo
test.mp3: Audio file with ID3 version 2.2.0, contains: MPEG ADTS, layer III, v2,  80 kbps, 24 kHz, Monaural
test.mpg: MPEG sequence, v1, system multiplex
test.wma: Microsoft ASF
  • Open terminal, then launch it as command totem open that file with the issue. Then post output if any error. – user.dz Sep 2 '15 at 18:28
  • @Sneetsher No output to console at all. totem just thinks it plyas the sound for the appropriate duration. Also, maybe I was not clear enough, this problem occurs with all sound or video files – Hagen von Eitzen Sep 2 '15 at 20:57
  • What type of files you have tried ? Could you check if gstreamer1.0-libav & gstreamer1.0-pulseaudio are installed – user.dz Sep 2 '15 at 21:31
  • 1
    @Sneetsher "all" types of files. And both gstreamer1.0-* are already installed – Hagen von Eitzen Sep 3 '15 at 17:51
  • Please install pavucontrol via sudo apt-get install pavucontrol, start via pavucontrol, start totem and play a mp3 or something else. Now make a screenshot of the tab "Playback" in pavucontrol and add the screenshot into your question. – A.B. Sep 11 '15 at 8:17
2
+50

There are two separate locations where an individual application's volume can be controlled, and if either is muted, no sound will be played. You say that the volume in Totem is set to maximum, but there is another place where it can be controlled. If you check Sound Settings, you'll notice that the rightmost tab is labelled 'Applications'. In the case that Totem is shown muted in this control, it is still possible to independently adjust the volume within the application, but you will not get sound output.

This image shows Totem with the volume up, playing a song. The visualisation is going, and you would expect to hear sound.

Unmuted Totem window

This image shows the Sound Settings with the computer volume on, but the application volume for Totem (Videos) off. Even though inspection of the volume from within Totem would suggest that the music should be playing, nothing gets to the speaker because of the mute control here. Note that Totem has to actually be running, or a volume control for it won't be visible.

Sound settings showing Totem muted

| improve this answer | |
1

Install the "pavucontrol" app, and use it to see the output levels from Totem, then you can reset the output device for Totem to the correct one. Once this is done it should be persistent.

| improve this answer | |
  • Thank you! This worked for me: I have 4 output devices, but Totem was set to the one that does not work (Built in audio). Screenshot: imgshare.io/image/Np9fqw – user1205127 May 25 at 22:06
1

For some reason Totem was outputting though an hdmi port even though the system output device was the main speaker, switching the output to the hdmi and back made totem output to the correct place again.

| improve this answer | |
-1

first of all uninstall totem and excute sudo apt-get install -f then reinstall totem
or try This it will works for you

Cheers

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.