2

Whenever I try to install any software using ubuntu software center or from command line, I get this dependency problem. I cant seem to resolve dependencies easily

Correcting dependencies... failed.
The following packages have unmet dependencies:
libc-dev-bin : Depends: libc6 (< 2.16) but 2.19-18 is installed
libc6 : Breaks: locales (< 2.19) but 2.13+git20120306-3 is installed
libc6:i386 : Recommends: libc6-i686:i386
          Breaks: locales (< 2.19) but 2.13+git20120306-3 is installed
libc6-dbg : Depends: libc6 (= 2.15-0ubuntu10.7) but 2.19-18 is installed
libc6-dev : Depends: libc6 (= 2.15-0ubuntu10.7) but 2.19-18 is installed
libc6-i386 : Depends: libc6 (= 2.15-0ubuntu10.7) but 2.19-18 is installed
libnih1 : PreDepends: libc6 (< 2.16) but 2.19-18 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

The output of apt-get cache policy libc-dev-bin

libc-dev-bin:
Installed: 2.15-0ubuntu10.7
Candidate: 2.15-0ubuntu10.12
Version table:
2.15-0ubuntu10.12 0
    500 mirror://mirrors.ubuntu.com/mirrors.txt/ precise-updates/main amd64 Packages
    500 http://rw.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
2.15-0ubuntu10.11 0
    500 mirror://mirrors.ubuntu.com/mirrors.txt/ precise-security/main amd64 Packages
   500 http://security.ubuntu.com/ubuntu/ precise-security/main amd64 Packages
*** 2.15-0ubuntu10.7 0
    100 /var/lib/dpkg/status
 2.15-0ubuntu10 0
   500 mirror://mirrors.ubuntu.com/mirrors.txt/ precise/main amd64 Packages
    500 http://rw.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

The output for apt-cache policy libc6

Installed: 2.19-18
Candidate: 2.19-18
Version table:
*** 2.19-18 0
    100 /var/lib/dpkg/status
 2.15-0ubuntu10.12 0
    500 mirror://mirrors.ubuntu.com/mirrors.txt/ precise-updates/main amd64 Packages
    500 http://rw.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
 2.15-0ubuntu10.11 0
    500 mirror://mirrors.ubuntu.com/mirrors.txt/ precise-security/main amd64 Packages
    500 http://security.ubuntu.com/ubuntu/ precise-security/main amd64 Packages
 2.15-0ubuntu10 0
    500 mirror://mirrors.ubuntu.com/mirrors.txt/ precise/main amd64 Packages
    500 http://rw.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

output for apt-cache policy locales

locales:
Installed: 2.13+git20120306-3
Candidate: 2.13+git20120306-3
Version table:
*** 2.13+git20120306-3 0
    500 mirror://mirrors.ubuntu.com/mirrors.txt/ precise/main amd64      Packages
    500 http://rw.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
    100 /var/lib/dpkg/status
  • Edit your question and add the output of apt-cache policy libc-dev-bin;apt-cache policy libc6 – A.B. Sep 2 '15 at 16:12
  • What A.B. meant is that you should run those two commands in a terminal and then add their output on the terminal to this question – kos Sep 10 '15 at 3:47
  • i cant believe i added the commands, thanks @kos – Eliethesaiyan Sep 10 '15 at 4:13
  • Edit your question again and give me the output of apt-cache policy locales – A.B. Sep 10 '15 at 4:50
0

Answer in progress

Downgrade the packages libc6 and libc6:i386

sudo apt-get install libc6=2.15-0ubuntu10.12
sudo apt-get install libc6:i386=2.15-0ubuntu10.12

You have installed version 2.19-18 and this version blocks the installation of libc-dev-bin

After that

sudo apt-get install -f
  • Start with my answer and give me a comment. I believe, we need a little bit more to repair you system. – A.B. Sep 10 '15 at 4:53
  • i got this You might want to run apt-get -f install' to correct these: The following packages have unmet dependencies: libc6 : Depends: libc-bin (= 2.15-0ubuntu10.12)` ` Breaks: libc6:i386 (!= 2.15-0ubuntu10.12) but 2.19-18 is to be installed libc6:i386 : Recommends: libc6-i686:i386` and at the end the suggested to run the last command you suggested – Eliethesaiyan Sep 10 '15 at 4:59
  • Do the downgrade also for libc6:i386 . I have changed my answer – A.B. Sep 10 '15 at 5:02
  • it gives this ` sudo apt-get install libc6=2.15-0ubuntu10.12` Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: ` libc6 : Depends: libc-bin (= 2.15-0ubuntu10.12)` Breaks: libc6:i386 (!= 2.15-0ubuntu10.12) but 2.19-18 is to be installed ` libc6:i386 : Recommends: libc6-i686:i386` Breaks: locales (< 2.19) but 2.13+git20120306-3 is to be installed – Eliethesaiyan Sep 10 '15 at 5:55
  • Please start sudo apt-get install libc6:i386=2.15-0ubuntu10.12 – A.B. Sep 10 '15 at 6:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.