6

I tried proposed solutions found here:

How do I install Skype?

How to install Skype 4.3?

and other places, but still no luck. My system was upgraded from Ubuntu 14.04 and Skype worked fine. Once I upgraded, Skype disappeared and I cannot install it. So after attempting a bunch of solutions found on the forum, I am still at the same place so when I enter this:

sudo apt-get install skype skype-bin

I get this

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skype-bin:i386 : Depends: libqtwebkit4:i386 (>= 2.2~2011week36) but it  is not going to be installed
                  Depends: libgl1-mesa-glx:i386 but it is not going to be  installed
E: Unable to correct problems, you have held broken packages.

If I enter this:

sudo apt-get install libqtwebkit4:i386

I get this

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libqtwebkit4:i386 : Depends: libgl1-mesa-glx:i386 but it is not going to be installed or
                          libgl1:i386
                 Depends: libqt4-opengl:i386 (>= 4:4.5.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

If I do this, note it is the same as above, but without :i386

sudo apt-get install libqtwebkit4

I get this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libqtwebkit4 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
  • refer here – Ravan Sep 2 '15 at 14:09
  • I did try that thread, dpkg --get-selections | grep hold produces no results. – user1135541 Sep 2 '15 at 14:13
  • Try this: change Ubuntu software to main server! – Ravan Sep 2 '15 at 14:14
  • You mean where http://us. is replaced with http:// in the file /etc/apt/sources.list? I just tried it, no luck. – user1135541 Sep 2 '15 at 14:25
  • 1
    Yet Another broken packages question: askubuntu.com/a/142808/32103 – Yurii Kolesnykov Oct 23 '15 at 15:59
1

Your packages are likely broken.

Proof that your packages are broken

I tested this with two different 64-bit 15.04 installs:

A) fresh 15.04 install (just did it this week) - installing skype works flawlessly with a standard approach of adding the partner repository then apt-get install skype.

B) fresh but overused 15.04 install - this box had a lot of additional software installed (over 15GB). It wasn't upgraded from a previous install like yours. I had exactly the same errors as you. None of the usual fixes out there would work (apt-get -f install / clean / autoclean / whatever - none worked)

This shows that the problem is with your packages. I even tried aptitude to solve the conflicts, but it wanted to uninstall over 500 packages from my system! (no, thanks!).

Possible Solutions

  1. Do a fresh install (15.10 will be available within a few days!)

or

  1. Try to use aptitude to see if it can give you a better solution in your specific case. I'll improve this post with examples upon request.

or

  1. Install all dependencies by hand to get Skype to run on your messed up 15.04 install (its probably not your fault it got messed up - this is likely a bug). I tested this and it works, so that I have Skype on both (A) and (B) above. Two ways you can attempt this:

    1. apt-get install recusivelly all packages above, forcing install when necessary, even though apt-get is complaining. I couldn't get this to work.

    or

    1. (worked for me) Install each library by hand by fetching it from the repository. It is more of a craft to get this right. However, it might be worthwhile since Skype is so central that you might well need it very badly. I will describe this in a couple more edits, but basically involves using ldd, apt-file find, apt-get download package_name:i386, dpkg -x package_name*.deb to decompress, then an ldconfig trick using /etc/ld.so.conf.d. I could just post all libs directly to you, but its 600MB worth of *.so's....
1
+25

First you should remove all skype related software you have had installed before.

Open a terminal and execute :

sudo apt-get purge '^skype.*'
sudo apt-get autoremove  

Open Nautilus - press Ctrl + H and delete the .skype folder in /home directory.

Now enable the Canonical partners repository to add it to the software sources.
Open Software & Updates, select Other Software and check Canonical Partners.

Microsoft skype is only available in a 32 bit version - so add the i386 architecture.

sudo dpkg --add-architecture i386  

Update the repositories :

sudo apt-get update  

Install skype and all dependencies :

sudo apt-get install skype
0

what you need to do it download Skype from there website.

Open up a Terminal by pressing Ctrl+Alt +T and then type in or copy in

wget http://download.skype.com/linux/skype-ubuntu-precise_4.3.0.37-1_i386.deb

install it by typeing in

sudo dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.deb

Skype needs has depends on some packages that are not installed we are going to install then by opening up a Terminal and type in

sudo apt-get install -f

after that you should have skype installed and working.

I have tested this on Ubuntu 15.04 32bit and it works.

0

I had similar problems with installation of other packages in Ubuntu before. I tried the following on a clean 15.04 Vagrant box with partner repositories enabled:

    $ apt-cache policy skype skype-bin libqtwebkit4:i386 libgl1-mesa-glx:i386
    skype:
      Installed: (none)
      Candidate: 4.3.0.37-0ubuntu0.12.04.1
      Version table:
         4.3.0.37-0ubuntu0.12.04.1 0
            500 http://archive.canonical.com/ubuntu/ vivid/partner amd64 Packages
    skype-bin:i386:
      Installed: (none)
      Candidate: 4.3.0.37-0ubuntu0.12.04.1
      Version table:
         4.3.0.37-0ubuntu0.12.04.1 0
            500 http://archive.canonical.com/ubuntu/ vivid/partner i386 Packages
    libqtwebkit4:i386:
      Installed: (none)
      Candidate: 2.3.2-0ubuntu7
      Version table:
         2.3.2-0ubuntu7 0
            500 http://archive.ubuntu.com/ubuntu/ vivid/main i386 Packages
    libgl1-mesa-glx:i386:
      Installed: (none)
      Candidate: 10.5.9-2ubuntu1~vivid2
      Version table:
         10.5.9-2ubuntu1~vivid2 0
            500 http://archive.ubuntu.com/ubuntu/ vivid-updates/main i386 Packages
         10.5.2-0ubuntu1 0
            500 http://archive.ubuntu.com/ubuntu/ vivid/main i386 Packages

After installing skype, I get the following output:

$ apt-cache policy skype skype-bin libqtwebkit4:i386 libgl1-mesa-glx:i386
skype:
  Installed: 4.3.0.37-0ubuntu0.12.04.1
  Candidate: 4.3.0.37-0ubuntu0.12.04.1
  Version table:
 *** 4.3.0.37-0ubuntu0.12.04.1 0
        500 http://archive.canonical.com/ubuntu/ vivid/partner amd64 Packages
        100 /var/lib/dpkg/status
skype-bin:i386:
  Installed: 4.3.0.37-0ubuntu0.12.04.1
  Candidate: 4.3.0.37-0ubuntu0.12.04.1
  Version table:
 *** 4.3.0.37-0ubuntu0.12.04.1 0
        500 http://archive.canonical.com/ubuntu/ vivid/partner i386 Packages
        100 /var/lib/dpkg/status
libqtwebkit4:i386:
  Installed: 2.3.2-0ubuntu7
  Candidate: 2.3.2-0ubuntu7
  Version table:
 *** 2.3.2-0ubuntu7 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/main i386 Packages
        100 /var/lib/dpkg/status
libgl1-mesa-glx:i386:
  Installed: 10.5.9-2ubuntu1~vivid2
  Candidate: 10.5.9-2ubuntu1~vivid2
  Version table:
 *** 10.5.9-2ubuntu1~vivid2 0
        500 http://archive.ubuntu.com/ubuntu/ vivid-updates/main i386 Packages
        100 /var/lib/dpkg/status
     10.5.2-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/main i386 Packages

As you see, the installed versions match candidates. You need to go over each package from this list that is already installed on your system and make sure it matches the candidate. How?

Let's look at the last package. In order to install the candidate version, run

$ sudo apt-get install -t vivid-updates libgl1-mesa-glx:i386=10.5.9-2ubuntu1~vivid2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgl1-mesa-glx:i386 is already the newest version.
libgl1-mesa-glx:i386 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Reasonably, I already had this version installed, but now it's going to be fixed to this version.

You may have some conflicting dependencies that you might have to resolve by removing other packages that depend on non-usual package versions (typically, from strange PPAs):

sudo apt-get purge package    
sudo dpkg -r package
sudo dpkg --purge --force-all --dry-run package

Thy those options in the given order and keep in mind that the last command can turn your installation into a trainwreck, so I put --dry-run there, which you have to remove by hand once you're confident about what you're doing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.