5

I installed pipelight and try to enable silverlight with

sudo pipelight-plugin --enable silverlight

And receive the message "Plugin silverlight5.1 is now enabled". But when I go to this page http://fds-team.de/pipelight/ with Firefox, the test is failed for silverlight. In about:plugins, there is no mention of silverlight whatsoever. Thanks

  • Have you tried running "sudo pipelight-plugin --create-mozilla-plugins"? – SuperSluether Jan 7 '16 at 17:51
6

If you don't have the user agent overrider for firefox search and install it under the add-ons in firefox. I use mine on windows/firefox 29 option

ensure that after running:

sudo pipelight-plugin --update

you need to run the following after accepting the licence agreement

touch $HOME/.config/wine-wininet-installer.accept-license

Close firefox if open (very important) then in a terminal window run

Sudo pipelight-plugin --create-mozilla-plugins
2

Remove old pipelight:

sudo apt-get remove pipelight

Now install:

 sudo apt-add-repository ppa:pipelight/stable
 sudo apt-get update
 sudo apt-get install --install-recommends pipelight-multi
 sudo pipelight-plugin --update

Install silverlight plugin:

sudo pipelight-plugin --enable silverlight

Before proceeding, it's strongly recommended to close your web browser. Without doing this, the plugin may fail to install or crash the browser

2

I experienced the exact same issue. Silverlight plugin did not show up in Firefox right after installing and enabling.

It seems the installer already enables Silverlight and a manual command does not really change that. All I had to do was disable Silverlight and enable it again:

sudo pipelight-plugin --disable silverlight

sudo pipelight-plugin --enable silverlight

Enabling the plugin again asks to accept 2 licenses. Do accept them, of course.

2

I am not a professional in Ubuntu but able to successfully run my pipelight-plugin in my firefox.

Go to this website http://fds-team.de/pipelight/ and find out what is the problem with the browser.

If its user agent related problem then download a useragent switching addon like User Agent Switcher,User Agent Changer etc and switch it to windows platform.

Else if the problem is related to installation of silverlight in your ubuntu then

close the browser and update the plugin

sudo pipelight-plugin --update

and retest with http://fds-team.de/pipelight/

if problem persists then try to disable and reenable pipelight

sudo pipelight-plugin --disable silverlight

sudo pipelight-plugin --enable silverlight
0

I had trouble with this also. Instead of : sudo pipelight-plugin --enable silverlight # I used the more times than I care to think about with no results.

I did :
pipelight-plugin --enable silverlight

I have absolutely no idea of why but it worked where the sudo addition did not.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.