0

I'm having a lot of problems with GCC. First, I tried to install an app (ginga) and I got a GCC depends issue. The depend is about have an gcc version, but the application needs other one. I installed the version asked, but the conflicts still. So, I got a lot of issues with GCC and now I can't install anything because of depends. When I try to install something a have this output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 build-essential : Depends: gcc (>= 4:4.4.3) but it is not going to be installed
                   Depends: g++ (>= 4:4.4.3) but it is not going to be installed
                   Depends: dpkg-dev (>= 1.13.5) but it is not going to be installed
 cpp-4.8 : Depends: gcc-4.8-base (= 4.8.4-1) but 4.8.5-1 is to be installed
 dkms : Depends: gcc but it is not going to be installed
 gcc-4.8 : Depends: gcc-4.8-base (= 4.8.4-1) but 4.8.5-1 is to be installed
           Depends: binutils (>= 2.24.90.20141219) but 2.24-5ubuntu13 is to be installed
           Depends: libgcc-4.8-dev (>= 4.8.4-1) but it is not going to be installed
 gcc-multilib : Depends: gcc (>= 4:4.8.2-1ubuntu6) but it is not going to be installed
                Depends: gcc-4.8-multilib (>= 4.8.2-5~) but it is not going to be installed
 libasan0 : Depends: gcc-4.8-base (= 4.8.4-1) but 4.8.5-1 is to be installed
 libatomic1 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but 4.8.5-1 is to be installed
 libc6:i386 : Depends: libgcc1:i386 but it is not going to be installed
 libgcc1 : Depends: gcc-4.7-base (= 4.7.2-5) but it is not going to be installed
 libgfortran3 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but 4.8.5-1 is to be installed
 libgl1-mesa-dri-lts-utopic:i386 : Depends: libgcc1:i386 (>= 1:4.7) but it is not going to be installed
 libglu1-mesa:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libgomp1 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but 4.8.5-1 is to be installed
 libitm1 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but 4.8.5-1 is to be installed
 libjack-jackd2-0:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libllvm3.5:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libmysqlclient18:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libqt4-declarative:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libqt4-network:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libqt4-opengl:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libqt4-script:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libqt4-scripttools:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libqt4-sql:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libqt4-sql-mysql:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libqt4-xml:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libqt4-xmlpatterns:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libqtcore4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libqtdbus4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libqtgui4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libqtwebkit4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libquadmath0 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but 4.8.5-1 is to be installed
 libstdc++-4.8-dev : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but 4.8.5-1 is to be installed
                     Depends: libgcc-4.8-dev (= 4.8.4-2ubuntu1~14.04) but it is not going to be installed
 libstdc++6 : Depends: gcc-4.9-base (= 4.9.1-16ubuntu6) but 4.9.3-4 is to be installed
 libstdc++6:i386 : Depends: gcc-4.9-base:i386 (= 4.9.1-16ubuntu6) but it is not going to be installed
                   Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
 libtsan0 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but 4.8.5-1 is to be installed
 sa-compile : Depends: gcc but it is not going to be installed
 simplescreenrecorder-lib:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Could you help me? I really don't know what to do.


pl_rock. First, thanks to help me.

I did what you suggest, but it didn't work. The answer for "apt-get -f install" is: E: Unable to correct dependencies

To purge the gcc I had to use "--force-all" and after purge gcc (4.8 and 4.9) a tried the apt-get autoremove, but I got the same output:

root@gleidson-Inspiron-5423:/home/gleidson# apt-get autoremove Reading package lists... Done Building dependency tree
Reading state information... Done You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: cpp-4.8 : Depends: gcc-4.8-base (= 4.8.4-1) but it is not installed dkms : Depends: gcc but it is not installed gcc-multilib : Depends: gcc (>= 4:4.8.2-1ubuntu6) but it is not installed Depends: gcc-4.8-multilib (>= 4.8.2-5~) but it is not installed libasan0 : Depends: gcc-4.8-base (= 4.8.4-1) but it is not installed libatomic1 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not installed libc6:i386 : Depends: libgcc1:i386 but it is not installed libgcc1 : Depends: gcc-4.7-base (= 4.7.2-5) but it is not installed libgfortran3 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not installed libgl1-mesa-dri-lts-utopic:i386 : Depends: libgcc1:i386 (>= 1:4.7) but it is not installed libglu1-mesa:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libgomp1 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not installed libitm1 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not installed libjack-jackd2-0:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libllvm3.5:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libmysqlclient18:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libqt4-declarative:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libqt4-network:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libqt4-opengl:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libqt4-script:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libqt4-scripttools:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libqt4-sql:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libqt4-sql-mysql:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libqt4-xml:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libqt4-xmlpatterns:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libqtcore4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libqtdbus4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libqtgui4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libqtwebkit4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libquadmath0 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not installed libstdc++-4.8-dev : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not installed Depends: libgcc-4.8-dev (= 4.8.4-2ubuntu1~14.04) but it is not installed libstdc++6 : Depends: gcc-4.9-base (= 4.9.1-16ubuntu6) but it is not installed libstdc++6:i386 : Depends: gcc-4.9-base:i386 (= 4.9.1-16ubuntu6) but it is not installed Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed libtsan0 : Depends: gcc-4.8-base (= 4.8.4-2ubuntu1~14.04) but it is not installed sa-compile : Depends: gcc but it is not installed simplescreenrecorder-lib:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed E: Unmet dependencies. Try using -f.

And, if I use the "-f" as suggest I got: E: Unable to correct dependencies.

0

you are getting this problem because you reinstalled gcc but there older dependency still exist that conflicting with new dependency . so run command :

apt-get -f install

it will resolve dependency then install gcc . if you still face problem then purge gcc and then run command :

 sudo apt-get autoremove 

it will remove older dependency then reinstall gcc and there dependency

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.