0

I am running Ubuntu 14.04 alongside windows 8.1 on an HP Envy 15 laptop having Nvidia gtx 850m graphic card. I was trying to setup the cuda programming environment as given here

https://www.udacity.com/wiki/cs344/ubuntu-dev

in the Ubuntu text only mode (obtained by the Ctrl+Alt+F1 combination)

For the cuda installation file, I downloaded the cuda_7.0.28_linux.run for ubuntu 14.04. When I executed the file, it reported some error (which I don't remember). However, on searching online, I found a solution which asked to stop the lightdm service and then execute the file. I did so and the installation worked perfectly fine. However, I did not restart the lightdm service and tried to switch from the ubuntu text mode to the GUI mode. On pressing the combo Ctrl+Alt+F7 the screen went dark with a cursor blinking on left hand top. After waiting for a while, I forced shutdown using the power button.

When I rebooted, I was stuck in the Ubuntu login loop problem. After extensive searching , I tried the following steps

a) dpkg reconfigure lightdm

b) remove and reinstall lightdm

c) install gdm and set it as default manager (for the concerned process)

However, none helped.

But after certain attempts, even the login screen stopped appearing. Now there is a black screen with a cursor on left hand top. After a few seconds, the screen seemingly refreshes and again the cursor starts blinking.

Now, is there any solution by which I get my ubuntu working without having to reinstall a fresh copy? Please help!!

1

The problem is that Nvidia driver cannot be correctly used by X Server. Uninstall everything like nvidia-*, it may help you solve the problem without reinstall the system, but I strongly suggest you to reinstall it if you are not an expert at Linux (I am not, so I have reinstalled several times my laptop in order to work with Cuda)

I have recently installed Cuda on my MSI GS60 (HD4600 + GTX860M + Ubuntu 14.04), I think my solution should work for you.

If you want to install Cuda while keeping Intel for display, my solution is for you. PS: it is not really my solution, but the solution on the official documentation, with more details:

  • Make sure you have a iXXX (i915 in my case) for Intel
  • Block nouveau device if you have
  • Download the runfile and set the correct access policy
  • Reboot into runlevel 3 (while choosing the system to boot, edit the boot info (tap E usually), replace "quiet splash" with "text", continue)
  • Run the runfile with "--no-opengl-libs"
  • Reboot normally

I hope it will help you.

| improve this answer | |
0

Follow the following steps

  1. Open Ubuntu in generic mode.
  2. Switch to console using Ctrl+Alt+F1.
  3. Log in
  4. sudo apt-get remove nvidia-*
  5. sudo apt-get remove cuda-*
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.