0

I have modified sublime text with themes and plugins on ubuntu 15.04 and this had to be done with sudo subl because with the unity launcher I had a permission error with package manager installation.

So I used sudo subl and I installed everything.

The issue is when I use unity launcher, the same old vanilla sublime text opens without any theme and when I use sudo subl in terminal I get the proper sublime text I intend to use.

However I want the unity launcher to launch the same application.

Also I saw the contents of "subl" in /usr/bin/subl its the same as those in sublime-text.desktop

What to do?

1

I solved it.

The problem was that the packages were installed in .config/sublime-text-3 and the owner of the directory was root, so the desktop entry did not have access to it.

sudo chown -R username:username /home/username/.config/sublime-text-3

The above command solved it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.