3

I have been searching for days on getting started with Linux and still can't get started.

I am running the following

CAELinux xunbuntu 12.04 I7 16 GB ram SSD 500 gb Nvidia GT 540M and an integrated graphics card.

I tried to follow the information from this link

sudo apt-get purge nvidia

sudo add-apt-repository ppa:graphics-drivers

sudo apt-get update

the following shows up. I don't know if this matters.

Note the .com was removed because I can 

W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://download.opensuse.org ./ Release: The following signatures were invalid: KEYEXPIRED 1396321314

then when I try to download the driver....

sudo apt-get install nvidia-352

Reading package lists... Done

Building dependency tree 

Reading state information... Done

E: Unable to locate package nvidia-352

At this point I tried the manual method from the same site.

but when I typed in

sudo service lightdm stop

I got a

"starting the virtual box Guest additions Fail!"
"modprode vboxguest failed"

and if I tried to type in my user name and hit enter what I typed just showed up in white text and enter did nothing.

Any help would be greatly appreciated. I have already reinstalled CAELinux xubuntu 12.04 four times to start fresh.

UPDATE

When I tried to allow the root user access to the X server:

xhost local:root

And point the command to the right DISPLAY:

sudo DISPLAY=$DISPLAY gedit /etc/profile

this was diplayed

gedit: command not found

I tried

sudo apt-get update && sudo apt-get install nvidia-352

and after all the update info it displayed

Unable to locate package nvidia-352

closed as off-topic by karel, Fabby, Pilot6, Eric Carvalho, David Foerster Sep 7 '15 at 20:31

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – karel, Fabby, Pilot6, Eric Carvalho, David Foerster
If this question can be reworded to fit the rules in the help center, please edit the question.

  • We're sorry, but this site is all about Ubuntu and its official derivatives as posted on wiki.ubuntu.com/Releases so CAELinux is off-topic here as well. However, on Unix & Linux, a sister site to Ask Ubuntu, they're very good at all varieties of Linux and Unix, so you might be better off there. ;-) – Fabby Aug 31 '15 at 20:41
3

First, lets get Ubuntu to a 'clean' state, without any nvidia drivers installed:

sudo apt-get purge $(dpkg -l | awk '$2~/nvidia/ {print $2}')

Next, let's remove the x-server error - follow this answer.

You can install the latest NVIDIA drivers by adding their new PPA to your system.

To do so:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update && sudo apt-get install nvidia-355

And as OMG! Ubuntu! say:
Remember: if the PPA breaks your system you are allowed to keep both halves. ;)

NOTE: The ppa works with versions 12.04.1 through to 15.10, so make sure you upgrade your version to the .1 release if you haven't already.

EDIT:Turns out you can't get the GT540M nvidia drivers to work on Linux.

Check out this answer.

  • Looks like I am using Ubuntu 12.04.5 LTS On the nvidia website 355 supported products is says "Quadro SDI: Quadro SDI" Should I be using 352 since I have a GT540M graphics card? – BaisJohn Aug 31 '15 at 15:58
  • OMG! Ubuntu! mentions about nvidia-355 "To upgrade to or install the latest Nvidia drivers" - after that, it's up to you – TellMeWhy Aug 31 '15 at 16:11
  • this is was happened when I tried allow root user access to x-server. sudo: gedit: command not found. I will add the whole thing in a reply – BaisJohn Aug 31 '15 at 16:15
  • @DecRobot please see updates to the questions. I am still having issues. – BaisJohn Aug 31 '15 at 16:45
  • @BaisJohn Okay, use "nano" instead - terminal text editor – TellMeWhy Aug 31 '15 at 18:28
0

it is normal if the GPG Key EXPIRE.

Purge your driver and install the "official" ppa driver repository:

http://www.webupd8.org/2015/08/new-official-proprietary-gpu-drivers.html

Not the answer you're looking for? Browse other questions tagged or ask your own question.