8

After discharging the battery completely, my notebook suspends instead of shutting down.
That happens regardless of using intel graphics or NVIDIA graphics mode on ubuntu 15.04.

Can this issue be kernel (3.19) related? Power behavior in ubuntu 14.10 (3.16) was correct.
To prevent the battery from getting damaged it is important that the machine shuts down.

As hibernation is disabled by default and not selectable in system settings, I wonder why -
power section in system settings is configured to power off the laptop - how can I fix this?

enter image description here

Hardware specifications:

  • SCHENKER XMG Advanced (CLEVO based) notebook series

  • i7-4710MQ | 16GB RAM | GTX 860M | 250GB SSD | 1TB HDD

  • intel Wireless AC-7260 + Bluetooth | 77 Wh Lithium battery

  • Hybrid graphics intel HD 4600 & NVIDIA GeForce + Optimus

GPU driver information:

  • nvidia-* (current stable) from Proprietary GPU Drivers PPA

Output from gsettings:

$ gsettings get org.gnome.settings-daemon.plugins.power critical-battery-action
shutdown
  • Could there be anything in the notebook bios/cmos settings? Or some kind of hardware setting that 14.10 possibly ignored and 15.04 does not. – Sri Sep 2 '15 at 4:46
  • Looks like what you did should have worked. I'm sure you have already looked, but (at least under KDE - which I know you don't use) there are several power settings for various conditions and maybe one of them is taking effect when it shouldn't - e.g. if battery low is not being detected for some reason. – Joe Sep 3 '15 at 17:14
4

Credits to @A.B. and @Serg for collaboration on solving this issue!
Recently we found the root cause for the problem and the solution:

  • In Ubuntu 14.04 default gsettings for critical-battery-action are set to 'suspend'.
  • In Ubuntu 15.04 default gsettings for critical-battery-action are set to 'shutdown'.
  • In Ubuntu 15.10 default gsettings for critical-battery-action are set to 'suspend'.

So the default setting has to be 'suspend'. You can change that by executing in terminal:

gsettings set org.gnome.settings-daemon.plugins.power critical-battery-action suspend  

Now the When power is critically low section in the system settings GUI has no entry any more:

This seems to be a bug in gsettings, as the 'suspend' setting leads to the 'shutdown' action.
As a contribution to help getting this curiosity fixed I filed a bug report at launchpad.net:

https://bugs.launchpad.net/ubuntu/+source/d-conf/+bug/1492174

Update : Status changed to 'Confirmed' because the bug affects multiple users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.