I really hope someone here can help, because I'm very close to giving up and moving back to Windows. I have an MSI GT70 Dominator with an i7-4710MQ 2.5 GHz, Intel HD 4000 (I'm pretty sure) integrated graphics card, and a GeForce GTX 970M/PCle/SSE2 dedicated graphics card. I started with a stock install of Ubuntu 14.04.3, and there is terrible screen tearing in every program I've tried, from Chrome to Minecraft to L4D2. I'm using the proprietary Nvidia drivers (version 346.82 from nvidia-346) because I've heard they get the best performance. By screen tearing, I mean that it's as though vsync is off- when something is moving, you can see horizontal lines where the frames are off.

I've tried going to Nvidia X Server Settings to turn on "Sync to VBlank", but the problem persists.

I tried installing Bumblebee as well, but when using the optirun command to open a browser and going to a Youtube video, the screen tearing is still there.

I've also tried going to usr/share/lightdm/lightdm.conf.d and editing the 5-xserver-command.conf to have the -bs option.

After some advice from reddit, I upgraded to 15.04, but that didn't work.

I tried setting my Nvidia power settings to high, no luck.

I've tried Compton and Compiz, neither did squat.

In nvidia-settings, the X Server Display Configuration, there is no screen displayed in "Layout", X Screen 0 is the only thing selectable in "Model", and whenever I try to Save to X Configuration File, it says "Failed to generate X config file!"

I've tried this link, nada.

I've rebooted after every attempted fix. I really want to use Ubuntu, but if this screen tearing persists, I might just have to go back to Windows, it's horribly distracting. Please, please, please help me. Any help anyone can give will be greatly appreciated, thanks!

  • tbh: How do I create the file /etc/X11/xorg.conf.d/20-intel.conf ? – user562821 Jun 29 '16 at 20:30
  • Open your terminal and type: sudo gedit /etc/X11/xorg.conf.d/20-intel.conf. Then save the file normally. – Michal Polovka Jun 29 '16 at 20:44
up vote 36 down vote accepted

Create /etc/X11/xorg.conf.d/20-intel.conf containing

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TearFree"    "true"
EndSection

That should fix everything.

Source is https://wiki.archlinux.org/index.php/Intel_graphics#Tear-free_video

Note: This only works if you're using bumblebee.


Note from comments: Since 10.10 the config file directory is now /usr/share/X11/xorg.conf.d

Starting from Ubuntu 16.04 LTS * you can use the following script to switch between NVIDIA and INTEL's graphics cards and besides it corrects the video/screen tearing on INTELs environment: https://github.com/bauca/graphics-switcher

  • 2
    I used a variant of this. I added the "TearFree" option to /etc/X11/xorg.conf instead, under the Intel device section. Thanks!! – smit3119 Sep 3 '15 at 11:28
  • 13
    Note that since 10.10 the config file directory is now /usr/share/X11/xorg.conf.d (wiki.ubuntu.com/X/Config). – Josh Feb 13 '16 at 3:39
  • 13
    Option "TearFree" "false" lol why does this setting even exist? – Dan Ross Mar 18 '16 at 12:42
  • 7
    Confirmed this works for Lubuntu 15.10 with intel graphic. I don't understand why you said This only works if you're using bumblebee – Hieu Mar 24 '16 at 2:35
  • 3
    @DanRoss It's important to bear in mind that the X server has to deal with an array of different hardware, kernel and driver configurations thus containing numerous workarounds for various bugs originating elsewhere. Workarounds are however tricky as they can be the cause of issues with other system configurations that do things correctly and thus don't need them and testing every possible system configuration is impossible. Thus there are good reasons why it is important to be able to selectively disable workarounds and also allow developers to test fixes to underlying code. – MttJocy Jul 31 '16 at 5:56

protected by Community Jul 31 '16 at 15:01

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.