4

Currently I cannot install some software.

sudo apt-get install vlc gives

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 vlc : Depends: libgles1-mesa (>= 7.8.1) but it is not going to be installed or
                libgles1
       Depends: libgles2-mesa (>= 7.8.1) but it is not going to be installed or
                libgles2
E: Unable to correct problems, you have held broken packages.

Trying to install libgles via Syanptic gives

enter image description here

Which when checking in Syanptic is clear:

enter image description here

Trying to force a specific version back down to 10.5.2 seems to indicate it's going to install a lot of my things which I have configured nicely:

enter image description here

Obviously I don't want to do this, but I would like to be able to use this PC again.

They don't appear in the to be installed list:

enter image description here

grep -r 'ricotz' /etc/apt/ gives:

grep: /etc/apt/trustdb.gpg: Permission denied

sudo grep -r 'ricotz' /etc/apt/ gives no output

sudo apt-cache policy libglapi-mesa gives:

libglapi-mesa:
  Installed: 10.6.0~git20150423.125574d1-0ubuntu0ricotz~utopic
  Candidate: 10.6.0~git20150423.125574d1-0ubuntu0ricotz~utopic
  Version table:
 *** 10.6.0~git20150423.125574d1-0ubuntu0ricotz~utopic 0
        100 /var/lib/dpkg/status
     10.5.2-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ vivid/main i386 Packages

sudo apt-get install libglapi-mesa=10.5.2-0ubuntu1 gives:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 monodoc-browser : Depends: libwebkit1.1-cil (>= 0.3) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

sudo apt-cache policy libwebkit1.1.cil gives:

libwebkit1.1-cil:
  Installed: 0.3-6
  Candidate: 0.3-6
  Version table:
 *** 0.3-6 0
        500 http://gb.archive.ubuntu.com/ubuntu/ vivid/main i386 Packages
        100 /var/lib/dpkg/status

Steps from A.B.'s answer:

nikolai@dante:~$ sudo apt-get autoremove
[sudo] password for nikolai: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
nikolai@dante:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
nikolai@dante:~$ sudo apt-get install libglapi-mesi=10.5.2-0ubuntu1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libglapi-mesi
nikolai@dante:~$ sudo apt-get install libglapi-mesa=10.5.2-0ubuntu1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 monodoc-browser : Depends: libwebkit1.1-cil (>= 0.3) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
  • Edit your question and add the output of grep -r 'ricotz' /etc/apt/ – A.B. Aug 30 '15 at 15:51
  • And the output of apt-cache policy libglapi-mesa – A.B. Aug 30 '15 at 15:53
  • Ok, seems to be a bigger job. Start again with my answer, I have added a step. Give me a ping with @A.B. – A.B. Aug 30 '15 at 17:30
  • Have you aptitude installed? – A.B. Aug 30 '15 at 17:45
  • @A.B. I don't. I can try and install it. I've added the out put from your answer. Many thanks. – NikolaiDante Aug 30 '15 at 17:47
2

The simple solution could be

Downgrade the package libglapi-mesa via

    sudo apt-get install libglapi-mesa=10.5.2-0ubuntu1

You have installed version 10.6.0~git20150423.125574d1-0ubuntu0ricotz~utopic from a PAA, that's not longer exist in your system or manually via dpkg -i or an other tool.

But your system is pretty broken.

Work in progress...

In this case, there is no stubborn sequence of steps. You have to decide and act on their own. I can give you advice only.

Currently we have only Synaptic Package Manager, therefore use it:

  • Disable unnecessary PPAs and other repositories. You can re-add them later.

    enter image description here

    Use Reload

    enter image description here

  • All packages in the category Installed (local or obsolete) should be removed or downgraded

    First try a downgrade. If that's not possible, remove the package. Do this step by step, not all at once. After each removal, check the category Installed (auto removable) and remove the packages also. Be in mind, packages can be re-installed but you should not remove the kernel ;)

    From time to time it's necessary to restart Synaptic. But this assertion comes from my experience and does not have to be true.

    enter image description here

  • Remove packages that can be re-installed


Here are some points from the chat

  • Before you restart your system check

    • Is your desktop is still installed?

      apt-cache policy unity
      
    • Is your network manager is installed?

      apt-cache policy network-manager
      
    • Is your graphic installed

      nvidia-settings --version
      

Be in mind and helpful links

  • 1
    I've accepted your answer, but theres a few extra steps from the chat that could do with being added. Many thanks :) – NikolaiDante Aug 30 '15 at 21:55
  • I'll read the chat and make the modifications a little bit later today. – A.B. Aug 31 '15 at 4:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.