0

I'm trying to install Evernote on Ubuntu using Wine. When I try to load Evernote's executable with Wine, before the installer comes up, I get the following program error:

The program msiexec.exe has encountered a serious problem and needs to close.

In terminal, here is the beginning of the error:

err:secur32:SECUR32_initSchannelSP TLS library not found, SSL connections will fail
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. 
 /wrap/Make sure that ntlm_auth >= 3.0.25 is in your path. 
 /wrap/Usually, you can find it in the winbind package of your distribution.
fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenElevationType, ...) semi-stub
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
fixme:storage:create_storagefile Storage share mode not implemented.
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
wine: Unhandled page fault on read access to 0x00000000 at address 0xf7627706 (thread 0026), starting debugger...
Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0xf7627706).
Register dump:
 CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
 EIP:f7627706 ESP:0033fb1c EBP:0033fb28 EFLAGS:00010206(  R- --  I   - -P- )
 EAX:0000007b EBX:7ebaa000 ECX:0018189a EDX:00000000
 ESI:0014eb28 EDI:00181508
Stack dump:
0x0033fb1c:  7ebaa000 0014eb28 00181508 0033fb88
0x0033fb2c:  7eb4e815 0014f110 00000000 0033fb68
0x0033fb3c:  7ebaa000 0000003b 00181878 0033fb88
0x0033fb4c:  7eaf9618 001370a8 0018189a 00000000
0x0033fb5c:  0014f110 00110000 00000000 00181508
0x0033fb6c:  f9f83000 001356c0 001818a4 7eb4e6fd
000c: sel=0067 base=00000000 limit=00000000 32-bit r-x
Backtrace:
=>0 0xf7627706 strstrW+0x16() in libwine.so.1 (0x0033fb28)
  1 0x7eb4e815 in msi (+0x5e814) (0x0033fb88)
  2 0x7eb501b8 in msi (+0x601b7) (0x0033fbc8)
  3 0x7eb06f21 in msi (+0x16f20) (0x0033fc28)
  4 0x7eb3a621 MsiInstallProductW+0xd0() in msi (0x0033fc78)
  5 0x7ebd9c11 WinMain+0x740() in msiexec (0x0033fd58)
  6 0x7ebd8984 main+0xd3() in msiexec (0x0033fdf8)
  7 0x7ebdb2df in msiexec (+0xb2de) (0x0033fe48)
  8 0x7b85a72c call_process_entry+0xb() in kernel32 (0x0033fe68)
  9 0x7b85b73a in kernel32 (+0x4b739) (0x0033fe98)
  10 0x7bc74e90 call_thread_func_wrapper+0xb() in ntdll (0x0033feb8)
  11 0x7bc77c2f call_thread_func+0xce() in ntdll (0x0033ffa8)
  12 0x7bc74e6e RtlRaiseException+0x21() in ntdll (0x0033ffc8)
  13 0x7bc4cca7 call_dll_entry_point+0x756() in ntdll (0x0033ffe8)
  14 0xf762615d wine_call_on_stack+0x1c() in libwine.so.1 (0x00000000)
  15 0xf76262d0 wine_switch_to_stack+0x1f() in libwine.so.1 (0xffbfdd28)
  16 0x7bc520e7 LdrInitializeThunk+0x336() in ntdll (0xffbfdd88)
  17 0x7b861333 __wine_kernel_init+0x872() in kernel32 (0xffbfeee8)
  18 0x7bc52663 __wine_process_init+0x162() in ntdll (0xffbfef68)
  19 0xf7623dc7 wine_init+0x306() in libwine.so.1 (0xffbfefc8)
  20 0x7bf00d52 main+0x81() in <wine-loader> (0xffbff418)
  21 0xf743a72e __libc_start_main+0xdd() in libc.so.6 (0x00000000)

My versions are as follows:

  • Ubuntu: 15.05
  • Wine: 1.6.2
  • Evernote: 5.0

I've tried several versions of Evernote but, as per the Wine application data base (here), 5.0.x or 5.8.x seems to be the most stable. All of the different versions of Evernote that I've tried give the same error.

1

The latest beta (5.9.3.xxx) takes one step forward on Wine - the note previews now change when you click on a note - and one step back: the note editing toolbar (which usually pops up when you click in a note to edit it) doesn't appear, and the title appears, but is not editable. If anyone has suggestion for native libraries to add or anything that might help, then please post!

For reference, the last version that works very well under Wine for me is Evernote_5.8.14.8221.exe, which can probably be downloaded somewhere...

0

I have been on that train for many days as well. I also got the immediate prompt with error on msiexec....

Tried so many things like installing corefonts, any imaginable library and/or fiddling around with the 32bit prefix. No succes.

But I finally (almost) solved it for ubuntu 15.04 desktop x64 running wine 1.7.

  1. I removed any (i really mean any) reference to wine. SO use apt-get to remove wine and winetricks. --purge
  2. removed the ~/.wine folder
  3. remove any reference in files on your system. I used the brute force like

     sudo find / -name *wine*
    

    Deleted them except the .wintricks cache

  4. sudo apt-get autoremove
  5. sudo apt-get clean
  6. sudo apt-get update
  7. sudo apt-get install wine1.7 winetricks

    for this to work you need to add the wine repo first. Else stick with wine 1.6

  8. start wine config
    • asks for mono and gecko installs. Just do so...
    • windows 7 mode
  9. start winetricks
    • default prefix
    • install font
    • installed corefonts, tahoma, consolas and some others.
  10. now launch the evernote installer. I used the most current of today 5.9.something and it finally installed all ok.
  11. now I only need a fix for the message that Evernote thinks I am offline...

If you manage at point 11... I'd be happy to hear!

Cheers Alex

0

I just used playonlinux and installed with multiple versions of wine. I think 1.7 and above work.

Only problem now is the previews don't work. When I click on a note it doesn't show the preview in the right window pane.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.