0

I am using the edkolev/promptline.vim theme(just installed it) for customizing the bash prompt. The biggest problem is that whenever I type long comments it replaces the prompt instead of continuing to the newline. Earlier when I used to have my prompt set via PS1 I could easily solve out the problem. But here I don't know which files to look and what to do .I am attaching the screenshot.

enter image description here

As you can see in the second line When I type sudo vim slices.vim it overwrites it. So, How can I solve it?

UPDATE 1.0 -> I could not found a solution to this problem , I assume there is a bug in the plugin. Instead of this I installed powerline . It solved all my problems. Installing it through vundle eased my way.

UPDATE 2.0 (not a bug actually)-> The demon arrives again.The problem has started again even with the powerline.This time I noticed that this problem is connected with the *arrow-shaped triangular prompt * only. So , this is not a bug, basically a glitch somewhere I am missing.

8
  • 1
    Is this your problem? – kos Aug 29 '15 at 10:12
  • @kos This is also a problem ,i.e pressing the UP arrow key results in the problem in your link , also my problem which is the commands replaces itself or the prompt. I don't the think that I would have the same solution because I am not using $PROMPT_COMMAND in bashrc because I am using a theme (promptline ) which I assume has settings somewhere else like in the /autoload/promptline.vim/slices.vim but I don't know how to edit it to solve my problem – 0decimal0 Aug 29 '15 at 11:05
  • Looks like a bug with that prompt. Have you contacted the author or filed a bug report? – glenn jackman Aug 29 '15 at 11:34
  • I have stated the problem in issues but got no response up till now . – 0decimal0 Aug 29 '15 at 11:46
  • This symptom usually occurs when in bash's PS1 the control characters (escape sequences that do not advance the cursor but rather set colors etc.) are not enclosed between \[ and \]. These delimiters around escape sequences are required so that bash can keep track of the columns. – egmont Aug 29 '15 at 12:55
0

I solved the problem .I think the shell was not using ~/.local/lib/python2.7/...../bindings/bash/powerline.sh so I resourced it and restarted the system.

I also added the path variable for powerline-config file in the ~/.local/bin/poweline directory in .bashrc and now, everything is working just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.