0

I want to install g++ on my laptop(ubutu 14.04 LTS), however it shows the following errors-

maddman@MADDY-PC:~/Desktop$ sudo apt-get install g++

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

g++ : Depends: g++-4.8 (>= 4.8.2-5~) but it is not going to be installed

E: Unable to correct problems, you have held broken packages.

Unable to correct problems, you have held broken packages.

Also every time i run update, it shows following error

W: Failed to fetch http://ppa.launchpad.net/picaso/octave/ubuntu/dists/trusty/main/binary-amd64/Packages 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/picaso/octave/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

0

After Some search, i found a relevant answer here... How do I resolve unmet dependencies after adding a PPA?

However, for me the following command worked out

sudo apt-get install ppa-purge

and then i ran the command for installing g++ and it installed successfully.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.