4

I'm trying to get the frequency of my CPU on max

I can't seem to change anything via cpupower or cpufreq-utils, or even by modifying the files myself at /sys/devices/system/cpu/intel_pstate

So I added inteal_pstate=disable to grub

Now I have no driver, I heard I have to load the acpi_cpufreq driver but I don't have it.

What do I do?

6
  • 1
    If you can not simply set performance mode with the intel_pstate driver, then you will have to give us more information about your system. And note that even in performance mode, the CPU frequency will not be locked at maximum. If the load is light enough the processor itself can back off the CPU frequency. – Doug Smythies Sep 1 '15 at 18:53
  • I have included some more information – mchid Sep 1 '15 at 23:12
  • I already know all that :( but frequency stays at 1.20GHz when it could up to 2.60GHz in theory. That's why I've disabled intel_pstate through grub but it still doesn't work – David 天宇 Wong Sep 2 '15 at 0:16
  • Is your computer a LapTop or? When frequency stays at 1.20GHz, is that after a suspend and when the intel_pstate driver is in performance mode? If yes, note that a patch was submitted for that scenario, and is included in kernel 4.2, which you could try as a test. – Doug Smythies Sep 2 '15 at 18:50
  • no it's a server – David 天宇 Wong Sep 2 '15 at 23:53
3

First of all, leave it disabled.

You do have a "driver" otherwise your computer wouldn't work. Run the following commands to install indicator-cpufreq:

sudo apt-get update
sudo apt-get install indicator-cpufreq

To start it up the first time, run the following command:

indicator-cpufreq &

It should start up automatically next reboot.

An icon will appear on your upper panel. Click on the icon to set the CPU frequency.

If you need to install acpi, run the following commands:

sudo apt-get update
sudo apt-get install acpi-support acpid acpi

Or, if you just need cpufreq:

sudo apt-get update
sudo apt-get install cpufreqd cpufrequtils 

EDIT

You need to disable pstate by editing /etc/default/grub and then you need to run sudo update-grub to update grub before you reboot in order to use the acpi driver.

Also, you should still be able to change the governor when you are using intel_pstate by running:

sudo cpupower frequency-set -g powersave

or

sudo cpupower frequency-set -g performance

Additionally, to list your current governor, run the following command:

cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

To see available governors, run the following command:

cpupower frequency-info | grep "governors:"

Finally, to show real time frequency and additional information, you can install and use i7z.

To install i7z:

sudo apt-get update
sudo apt-get install i7z

To run i7z:

sudo i7z
1
  • I should have say I have only a console. After installing acpi via your commands and doing a cpupower frequency-info I get driver: intel_pstate again and I still cannot change the frequency – David 天宇 Wong Aug 31 '15 at 1:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.