0

Background: I dual-boot Ubuntu 14.04 and Windows 7

I recently bought a new Sandisk SecureAccess 32GB flashdrive and was trying to backup some stuff on it from my Ubuntu partition, and while trying to copy over a file, I closed the Files window and the copying stopped. When I tried to copy over again, it said the drive is write protected, and I can't delete the old incomplete file nor copy over anything.

  • I tried to use Gparted, but it failed and said that the drive is write protected.
  • I followed this tutorial and neither method worked. I
  • I tried the selected answer for this question, and that didn't work either
  • Then I tried the answer from this question. I rebooted into Win7 and tried using the tool, and that didn't work. So I tried the long way posted, and thats where things got interesting. According to Diskpart:

DISKPART> lis dis

Disk ### Status Size Free


Disk 0 Online 698 GB 1024 KB

Disk 1 Online 28 GB 0 B

Apparently the 0B is for the flashdrive, and denotes it's full. continuing the tutorial, det dis returns:

DISKPART> det dis

SanDisk Ultra USB Device
Disk ID: 00000000
Type   : USB
Status : Online
Path   : 0
Target : 0
LUN ID : 0
Location Path : UNAVAILABLE
Current Read-only State : Yes
Read-only  : No
Boot Disk  : No
Pagefile Disk  : No
Hibernation File Disk  : No
Crashdump Disk  : No
Clustered Disk  : No

  Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
  Volume 3     E                FAT32  Removable     28 GB  Healthy

So my flashdrive is neither set to be readonly but it is currently in a readonly state. Using Windows Explorer on Win7, it says my drive used 344MB and has 28.6 GB free. Has anyone ever encountered this issue? If so, how did you fix it? or is my drive bricked?

PS. Sorry about formatting, I'm still trying to get the hang of it.

1
  • try to format and create a new filesystem using gparted .. – heemayl Aug 28 '15 at 20:54
1

This problem can happen when you unplug the drive or interrupt it while it is still active. The controller of the drive notices that something went wrong and marks the drive as 'dirty'. It is about the same what can happen with a regular hard drive. A hard drive can usually be repaired by performing automatically or manually a repair action. With flashdrives it is a matter of good or bad luck. Sometimes it can be repaired, sometimes it enters a read-only state like yours did and unfortunately this is irreversible. So your flashdrive is bricked now and you can only try to rescue the data it contains.

0

A SanDisk flash that is permanently "readonly" is only valid for a warranty claim.
It cannot be made to work again.
Make a backup of your data.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.