0

I have been trying to play Xwing vs Tie fighter on Linux Ubuntu Mate in virtualbox with my playstation 3 controller. After a few attempts It worked but I rebooted and it stopped working.

If I load my snapshot from when it worked, it works again. Using dmesg | grep sony I saw 2 changes occurring between when it works and when it doesn't.

Note that the system always gets input and when it doesn't work the system just doesn't transfer the input to the game.

Example of when it works:

[ 1724.864749] sony 0003:054C:0268.0008: input,hiddev0,hidraw0: USB HID v1.11 Joystick [Sony PLAYSTATION(R)3 Controller] on usb-0000:00:06.0-1/input0 

Example of when it doesn't work:

[ 1316.913893] sony 0003:054C:0268.0007: input,hiddev0,hidraw1: USB HID v1.11 Joystick [Sony PLAYSTATION(R)3 Controller] on usb-0000:00:06.0-2/input0

The first change I noticed was the change of hidraw0 to hidraw1. The second change I noticed was the change of USB port: usb-0000:00:06.0-1 to usb-0000:00:06.0-2.

My mouse pointer of the VirtualBox is recognized as a device (Virtualbox USB Tablet) and is the cause of the issue: when the controller works, the mouse pointer is on usb 2-2 and on hidraw1. When the controller doesn't work, the mouse pointer is on usb 2-1 and on hidraw0 (It switched places with my controller).

My questions are:

Can I switch the devices back? If so, how?

Can I disconnect the pointer from port 1, connect my controller to port 1 and reconnect the pointer to port 2? If so, how?

How can I force to connect my mouse pointer to port 2 instead of 1? If so, how?

Are there any other solutions?

I have Googled about it and have been searching for 2 months now.

Thank you for reading and tell me what you think about it.

0

You can try disabling pointer integration by pressing CTRL-I and then just not clicking into the window. That will keep the mouse released from the window and it should work.

If not, you can try plugging your PS3 controller in during bootup before it gets to the GUI.

|improve this answer|||||
  • Thank you for the edit and the response, i'll try after my exams. I'll let you know how it worked out. – Joris Aug 28 '15 at 21:18
  • I have learned in the meantime that the USB Tablet also coordinates the mouse input correctly within the window of the virtual machine itself. I doubt that disabling pointer integration is going to work but I'll try after my exams. What does work is changing the pointer device under system in settings to PS/2 mouse. Would there be any possible way to change between the two while running the machine or just temporarily unmount USB Tablet? – Joris Sep 2 '15 at 9:04
  • No, you'd need to leave it at one or the other while it's running. You can just leave it as PS/2 mouse, since that's not really a problem causer. – Daniel Sep 2 '15 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.