9

I am trying to install texlive 2012. I am running Ubuntu 12.04. I followed the instructions here: How do I install the latest TeX Live 2012?

but I now get error messages such as "ulem.sty not found". What did I do wrong?

  • 1
    What instructions did you follow, exactly? there are several answers in the question you linked. As far as I can tell, ulem.sty is provided by package texlive-generic-recommended - perhaps that particular subpackage didn't get picked up as a dependency? – steeldriver Aug 28 '15 at 12:27
7

Use the following command sequence:

sudo add-apt-repository ppa:texlive-backports/ppa
sudo apt-get update
sudo apt-get install texlive-full
        

This will get you the complete TeXLive package constellation. It is over 1 GB of stuff, but you will never worry with missing packages again. Both texlive and texlive-base provide only a subset of packages for the economy of space.

| improve this answer | |
12

The answer from Luís might not be for everyone since it requires to download a lot of packages that you might not need.

ulem.sty can actually be found in a much smaller package (3 MiB instead of 1 000 MiB), namely texlive-generic-recommended:

sudo apt-get install texlive-generic-recommended
| improve this answer | |
  • Wonderful. It worked fine and solved my problem with Jupyter Notebook. – Eric Duminil Jan 8 '18 at 22:01
  • perfect answer, no need to add an extra PPA – gilbertohasnofb Jun 30 '18 at 13:42
  • Better answer. Fixed an issue I had rendering markdown to pdf with pandoc; "File `ulem.sty' not found" – Toby Wilson Feb 15 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.