I have an older desktop with an NVIDIA GeForce FX 5500, which means only the 173.xx versions of nvidia's drivers work.

In the "hardware drivers" thing, I selected the "proprietary drivers" option, and clicked "apply now", but then it switched right back to the "use open source driver", without any visible error message or anything.

So I tried to install it with apt: Reading package lists... Building dependency tree... Reading state information... Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

    # apt-get install nvidia-173
    The following packages have unmet dependencies:
      nvidia-173 : Depends: xorg-video-abi-11 but it is not installable or
                   xorg-video-abi-12 but it is not installable or
                   xorg-video-abi-13 but it is not installable or
                   xorg-video-abi-14 but it is not installable or
    E: Unable to correct problems, you have held broken packages.

Forcing did not help.

So I tried installing the proprietary drivers from here. I blacklisted nouveau, stopped X, and updated the ramdisk.

The installation failed with a bunch of errors, as you can see here.

I can't figure out what I should do to make it compile. I installed build-essentials, and my gcc version is 4.8.4. My kernel version is kernel 3.19.0-25-generic.

I searched online, and all I could find was info for newer drivers. The drivers worked fine in openSUSE 12.3, and nvidia had an official repo for prebuilt ones, but it seems to be defunct now, although there's bound to be an archive somewhere. Should I try to somehow install those binaries?

Or is there something else I should try?

Thanks in advance.

  • 1
    Since the kernel version is 3.19, you must have installed 14.04.3 or the enablement stack. The default kernel version for 14.04 is 3.13, and the default xorg version is different as well. To try and solve it, you might want to install the original 14.04: old-releases.ubuntu.com/releases/14.04.1. Aug 28, 2015 at 11:09
  • You can use nouveau drivers. They should work OK.
    – Pilot6
    Sep 15, 2015 at 22:06
  • @Pilot6 they've never worked right for me. The annoyances vary with each OS (and probably the different versions of nouveau, I don't jump around from OS to OS very often), but this time it was that the screen flickers randomly.
    – Thomas N
    Sep 17, 2015 at 1:26

3 Answers 3


Unfortunately, there is no way to make 173.xx work on anything past Ubuntu 10.04 (that's when I last used the nvidia drivers on Ubuntu).

My issue was that my computer only has the "old" PCI - that is, no PCI Express slots. As such, I had to find a graphics card that fits in there.

Luckily, I found a GeForce 6200 card (with PCI!) on eBay, which uses the nvidia-304 drivers. Now it works fine on 12.04.
This fix -- if you want to call it that -- will cost you about US$40, or whatever people are selling them for.

Good luck to anyone else who has this issue.

  • nvidia-173 works on 12.04.
    – Pilot6
    Sep 15, 2015 at 22:05
  • @Pilot6 not really. I tried, and got something about a symbol missing and that it couldn't load the driver. At that point, I was fed up with the whole thing, and basically "paid to make it go away". It may be a defeatist attitude, but I don't have all day to deal with this.
    – Thomas N
    Sep 17, 2015 at 1:23

There is a very easy solution for this issue. You just need to install Ubuntu 14.04.1.

I did it on ancient machine with GeForce FX 5200 using lubuntu-14.04.1-desktop-i386.iso.

I think you shouldn't download any updates during install (or better unplug network) and after first boot just use Ubuntu's drivers tool to install NVIDIA 173.14.39. After reboot you can fully update your system to 14.04.4 and it won't destroy NVIDIA's dependencies.

enter image description here

Switching to this driver gave me a little performance increase. Some old games works better (via PlayOnLinux) and it even solved an issue with one game. Videos also plays slightly better (including HTML5). SMTube works considerably good now.

Just don't upgrade your distribution above 14.04 :)

Here's the link where I got my ISO: http://cdimage.ubuntu.com/lubuntu/releases/14.04/release/


Problem: Can not install the driver 173.14.39 for Graphics Card Model NVIDIA GeForce FX 5200.

Solution: I have searched and read for a solution for this issue for many days. nvidia-173 (173.14.39) is the driver package for NVIDIA GeForce FX 5200 graphics card. I have followed these sources to Install nVidia GeForce FX 5200 driver in Lubuntu 14.04.1 and it WORKED. Games(AssultCube) and (Warzone 2100) runs smoothly now. Here is the pure solution with technical details:

nVidia site says: "Support for X.Org xserver version 1.15 was added to the 173.14.* legacy driver series with version 173.14.39. No further releases from the 173.14.* series are planned." Look here: https://nvidia.custhelp.com/app/answers/detail/a_id/3142/~/support-timeframes-for-unix-legacy-gpu-releases Supported cards for 173.14.39 driver: https://www.nvidia.com/object/IO_32667.html And here: https://www.nvidia.com/Download/driverResults.aspx/71302/en-us

On Ubuntu forums site: The latest version of Ubuntu that will support the 173.xx driver is Ubuntu 14.04.1. Look here: https://ubuntuforums.org/showthread.php?t=2293379

If you are doing a new Ubuntu installation, do not install any version above 14.04.1, and do not download any updates during installation.

First you must connect to internet and check that by browsing web pages for example.

To install from desktop:

  1. Go to Synaptic package manager then update package info.
  2. Go to Software & Updates -> Additional Drivers-> select nvidia driver 173.14.39 -> Apply.
  3. Once the driver is downloaded and installed, reboot your computer.

To Install from terminal:

  1. sudo apt-get update

  2. sudo apt-get install nvidia-173

  3. sudo reboot

You can fully update your system to 14.04.6 and it won't destroy nVidia's dependencies. it'll still be using the 14.04.1 kernel series and graphics stack. Don't upgrade your distribution above 14.04. To remove nVidia driver from the system: sudo apt-get remove --purge nvidia-* You can also install (Linux Mint 17.1). I think it has X.Org xserver version 1.15 and will work too. I solved this issue

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .