6

To cut a long story short: I have a specific case with application run in Wine. The thing is this application is not seeing my sound input device when this device is grabbed by PulseAudio. Unfortunately setting profile of this device to 'off' in Pulse Audio Control is not working properly, device is still somehow grabbed. I proved it by killing pulseaudio deamon - then application can see my recording device. But the problem is I have to have PulseAudio enabled in the same time for OUTPUT devices, otherwise I cannot hear the sound outputted by this application.

So the question is : how to config pulse audio (or recording device) in such a way that it won't be even 'seen' by pulse audio? I am using ubuntu 14.04

EDIT : I found this : https://jamielinux.com/blog/tell-pulseaudio-to-ignore-a-usb-device-using-udev/

Device dissapears from pulseaudio panels but pulseaudio still somehow blocks application from using my recording device.

2 Answers 2

0

Adapted from: https://ubuntuforums.org/showthread.php?t=1551820&page=2. Worked for me in Ubuntu 20.04

If you don't have PulseAudio Volume control installed:

sudo apt install pavucontrol

Then run pavucontrol in a terminal or via your desktop.

  • First select the Output Devices tab and make sure the drop down in the lower right corner is set to All output devices.
  • Then select the Configuration tab.
  • Find the device you want Pulse to ignore and select off in the profile drop-down.

In Ubuntu 20.04 I still saw the device in the sound options, but it did indeed seem to be available for use with Alsa. In my case the device is a USB DAC connected to my hifi amp. I am planning to set up MPD on that output but have not gotten that far. I did test with VLC by changing its audio configuration to ALSA and selecting the raw "hardware" device.

This profile setting seems to be remembered across reboots. I have not tested disconnecting and reconnecting the USB device but the referenced forum post indicate that it should work:

... by following the above instruction, I could get a particular driver to be ignored by setting it to "Off" in pavucontrol - proof is that I can insmod/rmmod the driver multiple times without pulseaudio getting a lock on it - even if pulseaudio recognizes the driver as loaded (and indeed, shows it in pavucontrol when it is).

0

As it has been said, you need to install pavucontrol (Pulse Audio Control).

  1. Open pavucontrol, by selecting Super + "pulse audio".

  2. Go to Config tab.

  3. Select the profile "turned off" or "disabled" for the device you want to keep turned off.

  4. Then click on the 'lock' icon at the right. That will keep the selected profile for that device, no matter if you disconnect it and then reconnect it.

As it's shown in the following image:

PavuControl interface example

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .