0

so I just put 15.04 on my computer, and the Wifi seems to be connecting to the router but there is no internet connection. I'll post many commands I have run following other questions on this site. Every command here ran fine except for sudo dhclient wlan0, which after Enter is hit just returns an empty line until I have to Ctrl + C out of it (not blank after it asks password, an empty line after sudo password is entered). Here is the information on my machine and network:

tyler@tyler-desktop:/$ iwconfig
eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"3535"  
          Mode:Ad-Hoc  Frequency:2.412 GHz  Cell: 4E:16:E0:97:CB:B8   
          Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

lo        no wireless extensions.


tyler@tyler-desktop:/$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:22:4d:82:42:b1  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:20 Memory:f7f00000-f7f20000

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:12739 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12739 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1038503 (1.0 MB)  TX bytes:1038503 (1.0 MB)

wlan0     Link encap:Ethernet  HWaddr 68:1c:a2:04:27:84  
          inet addr:10.42.0.1  Bcast:10.42.0.255  Mask:255.255.255.0
          inet6 addr: fe80::6a1c:a2ff:fe04:2784/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:9928 (9.9 KB)


tyler@tyler-desktop:/$ ping 5 google.com
ping: unknown host google.com
tyler@tyler-desktop:/$ ping -c5 8.8.8.8
connect: Network is unreachable


tyler@tyler-desktop:/$ sudo lshw -class network
  *-network               
       description: Ethernet interface
       product: 82579V Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eth0
       version: 04
       serial: 00:22:4d:82:42:b1
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k firmware=0.13-5 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:37 memory:f7f00000-f7f1ffff memory:f7f39000-f7f39fff ioport:f040(size=32)
  *-network
       description: Wireless interface
       product: RT2800 802.11n PCI
       vendor: Ralink corp.
       physical id: 1
       bus info: pci@0000:04:01.0
       logical name: wlan0
       version: 00
       serial: 68:1c:a2:04:27:84
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt2800pci driverversion=3.19.0-15-generic firmware=0.34 ip=10.42.0.1 latency=64 link=yes maxlatency=4 mingnt=2 multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:f7d00000-f7d0ffff


tyler@tyler-desktop:/$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.42.0.0       0.0.0.0         255.255.255.0   U     0      0        0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0


tyler@tyler-desktop:/$ rfkill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

My wireless card isn't one that I've seen before on these boards:

       product: RT2800 802.11n PCI
       vendor: Ralink corp.

Please help me! Thank you very much.

  • This is what's scaring me "My wireless card isn't one that I've seen before on these boards" If your wireless card isn't compatible, that would explain all of this. That may be the problem – David Aug 28 '15 at 3:07
  • I meant boards as in forums. It is a google-able card / company. :) – Tyler Brown Aug 28 '15 at 5:56
1

Based on you output, problem is default gateway. You are connected on roter and have ip: 10.42.0.1 with nm: 255.255.255.0 but in routing table you do not have default gateway. If you known ip address of you router add default gateway with this command

 sudo ip route add default gateway via ip_address_of_router

or if you don't known ip of router try with this command

 sudo ip route add default dev wlan0

Edit 1

That is the problem. Your interface have address 10.42.0.1 with mask 255.255.255.0. That mean that you can communicate with host from range 10.42.0.2 till 10.42.0.254. You can not try to set gateway 67.189.92.17.

Gateway is, usually, ip address from lan side of your router.

Ip address 67.189.92.17 is public ip address and probably you router have this address on wan interface.

I don't known right address of you router but I guess is 10.42.0.254.

Also you can run command arp to see all hoston your local lan. If you do not have success in setting a gw post output form arp command.

  • When I run the first one, I get Error: either 'to' is duplicate or 'gateway' is garbage and the second command runs then does nothing. Also, that IP isnt what I get when on other devices. Is there a way to directly target the IP for connection? – Tyler Brown Aug 29 '15 at 2:03
  • Please can you provide ke output from route -n and do again traceroute to 8.8.8.8 after you enter second command. Also give me output from command arp – 2707974 Aug 29 '15 at 11:07
  • tyler@tyler-desktop:/$ route -n Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 10.42.0.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0 169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 wlan0 tyler@tyler-desktop:/$ sudo ip route add default via 67.189.92.17 RTNETLINK answers: Network is unreachable tyler@tyler-desktop:/$ sudo route add default gw 67.189.92.17 SIOCADDRT: Network is unreachable tyler@tyler-desktop:/$ ping -c 5 8.8.8.8 connect: Network is unreachable Also command 'arp' didn't work – Tyler Brown Aug 30 '15 at 2:51
  • I edited my answer – 2707974 Aug 30 '15 at 8:16
1

Please note:

wlan0 IEEE 802.11bgn ESSID:"3535"
Mode:Ad-Hoc Frequency:2.412 GHz Cell: 4E:16:E0:97:CB:B8
Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off Power Management:off

Ad-Hoc mode is used for computer-to-computer connections, not computer-to-router connections (usually known as infrastructure). This often happens when a user uses Network Manager to 'Create New Wi-Fi Network.'

Please click the Network Manager icon, select 'Edit Connections' then Wireless and change the Mode from Ad-Hoc to Infrastructure. Save and close.

You may need to restart Network Manager:

sudo service network-manager restart

Or you may need to reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.