1

I installed Ubuntu 15.04 from a LiveUSB, and the install went well. However, my system always boots into Windows. boot-repair does not help in my case. How can I fix this?

BootRepair Log

  • 1
    What model PC do you have? – Kaz Wolfe Aug 28 '15 at 0:56
  • HP Pavilion TS Sleekbook 15 – Jack Li Aug 28 '15 at 1:02
  • It came with windows 8 sorry forgot to mention that – Jack Li Aug 28 '15 at 1:02
  • Hold ESC during startup, then press F9 to select a boot device. Ubuntu should show up there. Once you've booted into Ubuntu, open a terminal and enter sudo efibootmgr. Please add the output to your question so we can give you more help. (If efibootmgr isn't installed, use sudo apt-get install efibootmgr and then try again.) – Michael Hoffmann Aug 28 '15 at 1:21
  • 2
    What error (if any) is thrown by boot-repair ? Or does the boot-repair succeed ? – abhilash Aug 28 '15 at 1:27
2

You need to change the boot order on your laptop.

The manual for your computer (HP Pavilion TS Sleekbook 15) says to follow these instructions:

  1. Shut down the computer.
  2. Press the ESC key and turn on your computer.
  3. Press the F10 key to enter your BIOS Settings.
  4. Navigate to System Configuration.
  5. Navigate to Boot Option
  6. Move the Ubuntu entry to the top of the list.
| improve this answer | |
  • For most HP pavilion's, the boot order options only let you change which device gets booted first, not which bootloader. – Michael Hoffmann Aug 28 '15 at 1:17
  • @MichaelHoffmann It uses a legacy BIOS? – Kaz Wolfe Aug 28 '15 at 1:18
  • @MichaelHoffmann - Your BIOS should allow you to select which OS to boot, usually in the boot menu, sometime under security or secure boot or (U)EFI boot, it varies. If this is NOT AN OPTION, try updating your BIOS and contacting HP (HP is better then most with Linux support, although not perfect). – Panther Aug 28 '15 at 1:20
  • It has UEFI firmware, but it does have a legacy option for supporting operating systems designed for BIOS firmware. My laptop's the year-older model of the asker's, but I've spent a few weeks getting it to dual-boot, and not being able to specify the OS from the firmware menu is a big hangup for people with similar hardware in lots of forums. @Jack Li probably needs to change the boot order using efibootmgr, if he installed out of legacy mode (in regular UEFI mode), or he might be able to use bcdedit within Windows to change/add a boot entry for GRUB to Windows Boot Manager if in legacy. – Michael Hoffmann Aug 28 '15 at 1:28
  • @bodhi.zazen, updating the firmware does not fix this, and HP says it's how it should be. I disagree :) – Michael Hoffmann Aug 28 '15 at 1:30
0

Try entering this command in Command Prompt (NOT powershell) as administrator:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.