1

linux newbie problem:

/i've installed 14.04 on an acer aspire laptop and cannot get the wifi to work (no wifi symbol in taskbar even).

I've tried following the instructions here: https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

lspci -vvnn | grep -A 9 Network 0a:05.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)

Subsystem: AMBIT Microsystem Corp. TravelMate 2410 [1468:0312]  Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-   Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort-  <TAbort- <MAbort- >SERR- <PERR- INTx-

Latency: 32 Interrupt: pin A routed to IRQ 20   Region 0: Memory at d0004000 (32-bit, non-prefetchable) [size=8K]
Kernel driver in use: wl

0a:06.0 CardBus bridge [0607]: Texas Instruments PCIxx12 Cardbus Controller [104c:8039]

not sure that's pasted in right so I summarise: broadcom BCM4318 picid:[14e4:4318] kernel driver in use:wl

So I tried following the instructions down the page to install the B43 using the open-source firmware-B43-installer, and restarted, but that didn't solve the problem.

so I tried the next bit:

2.04 (Precise Pangolin) - 14.04 (Trusty Tahr) Open a Terminal and if you haven't already done so, update your package list:

sudo apt-get update

If you have a b43 card use the command

sudo apt-get install firmware-b43-installer

and restarted, again with no improvement, so to the next bit:

Switching between drivers

If you card is supported by more than one driver then use the modprobe command to test the drivers. First unload all conflicting drivers (this includes removing the driver you're trying to install):

sudo modprobe -r b43 bcma

sudo modprobe -r brcmsmac bcma

sudo modprobe -r wl

To load a specific driver use one of the following commands:

sudo modprobe b43

sudo modprobe brcmsmac

sudo modprobe wl

Allow several seconds for the network manager to scan for available networks before attempting a connection.

this is where I got stuck - the 1st two sudo modprobe -r commands were fine but when I try and remove the wl driver I get:

modprobe: FATAL: Module wl is in use.

I cannot see how to proceed from here so I would appreciate some direction.

rfkill list 0: acer-wireless: Wireless LAN  Soft blocked: no    Hard blocked: no

sudo iwconfig
[sudo] password for a: 
lo        no wireless extensions.

eth0      no wireless extensions.

not sure what other info I need to supply (complete linux newbie sorry). ethernet (wired) internet is working OK. Thx

  • According to that howto, bcm4318 is only supported by the b43 driver. Why then, do you have STA installed? – mikewhatever Aug 28 '15 at 0:40
  • hi mikewhatever; if you don't mind me asking, how did you figure out that the STA driver was installed? - I'd swear that Ididn't install it and could only see 'wl'. – mab Aug 28 '15 at 8:38
  • Thanks clili555 for giving this newbie the answer I needed - much appreciated. – mab Aug 28 '15 at 8:39
  • It's the wl module. It is provided by the bcmwl-kernel-source package, aka Broadcom STA. You must have had it installed at some point. – mikewhatever Aug 28 '15 at 8:42
  • For some reason the B43 driver was blacklisted - now I know I didn't do that. Just one more thing: the wireless LED on the laptop now flickers on and off as the (now working) wifi is used - in winXP it just stayed on - is this normal, or have I got something else to straighten out? – mab Aug 28 '15 at 8:42
2

Please do:

sudo apt-get purge bcmwl-kernel-source

Reboot and enjoy your wireless.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.